DXO Photolab and lightroom all versions

I am using lightroom as my DAM and transferring images to DXO photo lab for processing outwith Lightroom.


I open lightroom and select my folder within lightroom.

I then select the image I wish to process in DXO Phototolab via File- Plugin Extras - Transfer to DXO Photolab


DXO Photolab opens but it opens the previous image edited in DXO Photolab

I ave installed all updates to Lightroom and DXO Products but cannot resolve this behaviour. I am on a MAC O/S High Serria again fully updated.

Is there a bug or am I missing something…

Please advise

For what it is worth I have not seen this.

This is not my normal workflow as I do not use Lightroom very much, but I did what you suggested. I opened LR (CC, version 7.5), imported a folder of raw images, clicked on one and used the transfer functionality to open that image in PhotoLab (1.2.2, build 81) and only the proper image opened up.

What OS version are you using?

OS 10.13 on iMac

I tried this again this morning, but again everything worked properly on my machine. Perhaps you might think about uninstalling and reinstalling the components involved. If it were me I would uninstall and reinstall both Lightroom and PhotoLab, although I do not know if that would fix the issue.

Sorry I can not be more helpful.

Still happens.

  1. Transfer image to dxo edit save back

  2. Select different image and transfer previous image opens.

Maters not if I exit Lightroom or not.

Great forum. No response … Funny that the DxoVersion 9 Lightroom plug in works ok.
now dropping DXo photolab.