DxO Optics Modules CANNOT Download [SOLVED 2024-03-21]

I cannot download any optics mocules for any camera. No error message is displayed. Per DxO support I reinstalled PhotoLab 7 Elite and restarted my mac Studio: Every time I click “Download” the status is “Retry.”

Has anyone seen this issue and fixed it?


SOLVED: The technical team at DxO was able to fix issues with their system that caused this problem.

As of today I can download modules in PL7 at any time. I can also download DxO files from My Software in my account.

I was not given any details of the cause or solution but it is fixed for Safari.

I’ve had this at times, but it resolved itself after a retry or deleting the Modules folder.

  1. quit PhotoLab
  2. delete /Users/ReplaceByYourUserAccountName/Library/DxO PhotoLab v7/Modules
  3. restart PhotoLab
  4. retry the download

Did not work. PL7 recognizes a module is missing and offers to download all. When I click the “Download all” button it sets status to “Retry.”

Strange … I was able to download the modules a few minutes ago. It’s therefore not the server. Other items might stand in the way though:

  • Access rights to the folder (should be okay after deletion of the modules folder, because DPL adds the folder and the enclosed database and their privacy setting should match.
  • Modified file locations and/or access right settings
  • other

Have you tried downloading the modules manually from scratch with modules folder deleted before starting DPL and trying again?

I moved the entire PL7 folder out of the Library folder and restarted PL7. It recreated the PL7 folder in the Library and it was empty.
I then opened PL7 and tried to download modules again and it failed.

I then installed an older version of PL7 and tried the same thing and it failed. I have no idea why this stopped working. I have not needed to download a module for sometime so I don’t have idea what changes could cause this.

Is there a way to manually download modules from DxO directly without going through the app? They are obviously on a server so it would be great to have access to that directlry to download whatever modules I need outside of PL7.

Perhaps the server is busy. Try again in a few hours.

This has been happening for ocer 24 hours.

A few years ago, I had issues that were resolved (temporarily) by doing this:

  1. Create a new user account
  2. Launch PhotoLab
  3. Download modules
  4. Copy modules over to your normal user account
    → use the shared user account or the shared folder for the transfer

If module download works under the new user, your user account might need a reset. Again, this was a few years ago and things on macOS have changed. But resetting the user account might still do the trick.

If the problem is with access rights, Terminal.app can fix it with “tccutil reset All”. This will reset all the rights and they must be rebuild afterwards. Apps usually ask for access, and then, you can grant it or reject it. Tightening security too close can cause issues in daily use (if apps and OS don’t cooperate nicely due to whatever design flaws or bugs they carry)

Caveat: these steps aren’t standard mac user territory. If you feel too intimidated by a command line interface, you might want to inform yourself of possible implications.

DxO sent me a logging utility so I will send them diagnostics first.

UPDATE: Without any changes on my end it started working again. So I am assuming, but do not know, that something on DxO’'s end changed.

Another symptom was that using Safari to attempt to download the PL7 dmg file I would get an error that Safari could not find the server. This is a weird Safari problem that pops up sometimes. BUT, I was able to download the dmg file using Brave Broweser without any issue. Today Safari works too and could download the file. So the problem was with the DxO download URL for some reason.

UPDATE 2: A few hours later it stopped working again. I have reported this intermittent failure to DxO Support. It is very strange, Also, when using Safari I get the “cannot find server” error again when attempting to download any app. So whatever is happening it is in Apple’s infrastructure since I can download apps with Brave Browser, just not Safari.

Strange, I often re-download photoLab without any hickups - using the URL that you can find in the window that opens when you press command-I on a downloaded .dmg file…

I usually store the dmg files on the shared user. Keeping a few versions help to fall back, if it should be necessary.

NOTE: I can connect using a VPN. If I turn the VPN off I get the error again.

The problem is with Safari. Earlier today I could get to the URL. But now I get this:

But, I CAN download it using Brave Browser.

So, when I get the Safari error I can also NOT download modules from within PhotoLab 7.

I do not know what is causing this issue but it comes and goes without me changing anything. So it is not a network problem on my end because I can download using Brave Browser even when getting the Safari error.

I seems like whatever is causing the Safari error is also affecting the download process in PhotoLab7 because these issues come and go at the same time.

Looks Like PhotoLab is using the same OS Infrastructure Services as Safari. Maybe it could help if you started your Mac into recovery mode and installed maxOS again.

This problem was with DxO and they fixed it. No need to do any of the suggested fixes noted above. I find that when things go wrong my first option is to contact the source. If they cannot help or admit the problem is on their end only then would I even consider jumping through the hoops of restarting in safe-mode or reinstalling macOS. These things take a lot of time, and as in this case would have been a total waste of time since DxO fixed the issue on their servers.