DxO Optics 11 Can't download lens modules

Just bought new Canon EF 50mm f/1.8 STM for my Canon 5D Mark II, got some shots and want to edit them as usual. “DxO Optics Module installer” appear on a screen, asking to install new module. But nothing happens - downloading ends with error “Unable to connect to the remote server”.
I’m happy Windows 7 user, so upgrade to Photolab isn’t possible for me. Several days ago all was working fine, while I download modules for existing equipment in different combinations.
So, that’s all? No way to use a bit withered software?

Check whether or not this camera + lens combination is suported here:

@stuck that reference does not go back further than PhotoLab 1 and OpticsPro 11 was the release prior to that first PhotoLab release!

@equinox I have a copy of DxO OpticsPro 11 installed and it seems perfectly happy to pick up new lenses etc. as long as they were available at the time that version was active!

So your lens was released about May 2015 I believe?

My sons’s wedding was September 2015 and his wedding photos were taken on his Canon and the software is still asking me which lens I want to use?

Upload an image and I will see if it will give me the option to download the camera and the lens corrections!

Did you try to download something? I can get this list too, but it’s useless.
Also I have these strings in the C:\Users%USERNAME%\Documents\DxO OpticsPro 11 logs\DXOOpticsPro.txt

2023-10-25 21:35:06.455 | DXOOpticsPro - 9448 - 20 | IO - Error | Error while downloading file ‘http://download-center.dxo.com/Modules/C37223a_000.caf

downforeveryoneorjustme says:

It’s not just you! http://download-center.dxo.com is down.

Have you tried to download the lens manually?
Maybe a temporary glitch in the server?

Meanwhile, you could try the module I downloaded with DPL5 for Mac:
C37224a_000.caf.zip (87.0 KB)

Unzip the file and move it next to your other module files, wherever they may be on Win (there’s a post about the location, but I can’t find it now.

a path in Windows 10 …

@equinox my download for the lens used went through without any problems, but it was not the same lens as yours nor exactly the same Canon camera!

@Wolfgang the path for Opticspro is shown below

PS:- This database is read whenever DxPL 6 starts up,

and here is the entry for your camera and lens @equinox but this is the PL6 database

How this database is loaded I do not know!?

@equinox This is the entry in the OpticsPro database for the same lens that identifies the module for your camera which agrees with the module identified by @platypus but not with the module you got the error message for!?

If you upload an image I can try it with my copy of DxO.

@platypus do you believe it will work if @equinox copies the module you included into the correct OpticsPro location as you suggested (sorry I am suffering from a bad cold and not “firing on all cylinders”)?

I.e. unzip and copy to

where “Bryan Thomas” is replaced by @equinox’s username.

Currently that module is not part of my library of modules but I have downloaded C37223a_000.caf and C37224a_000.caf (which is also in the zip file supplied by @platypus) and can try the process if I have a suitable image!

I don’t believe in anything software…but @equinox can always try to see if it works.
Maybe the modules are different for Mac and Win? Again: try and see!

Many things in life are proposals. But time flows in one direction only.

@platypus Thank you for the response.

“Oh ye of little faith”, DxO are not especially illogical in the design of their software and they built it to be modular so that the cameras and lenses could be added.

However, yesterday I revisited my Photo Supreme Limited edition (no longer offered by IDimager) and attempted to remove an image and was offered the option to just remove the database entry, wouldn’t that simple option be so useful in PhotoLab!! However, I didn’t go looking for the option to add it back in!


I made my living out of designing and developing (and selling and installing and supporting) software (and my customers) and so did you I believe!?

If we consider belief to start where knowledge ends…we’d better make sure to know than to think that a guess is true. Nevertheless, I did write some code for real time call accounting systems some umpty years ago, when 2.5 MHz processor clocks were pretty darn fast, address space was limited to 64k bytes and processing had to be done in less than 100 ms for 1000 subscribers. Frontend microcontrollers were packaged in ceramics and got hot enough for second degree burns indeed.

and @equinox

DxO announced here (a long time ago) that it was dismantling Optics pro accesses server to save resources.
I don’t know why, but the optical modules code has evolved since then.

So much for licence for life

@Pieloe as I explained in a post above I have images from my sons’ wedding taken with a Canon 5D Mkiii and I went and found those images in OpticsPro 11 and was asked to select exactly which lens had been in use and, given I have no clue to what was being used, I selected one at random and a download took place and all was good to go!

Whatever DxO are doing with the OpticsPro support structure I do not know but I was able to download lens support successfully.

I would suspect that @equinox’s problem was a transient download problem but I cannot be sure, an image from the camera of a blank sheet of paper would be fine for me to test.

All I need is the camera and lens information in a suitable image and I could test it in minutes.

@equinox may not have a suitable upload speed which was a problem for me until a very persistent engineer bypassed an underground fault some months ago!

@platypus obviously not a major career in software development then!

Programming was not the main part of my job description, I started as UK Database Support principally for DMS II running on Burroughs Large Systems, and the early ones lived up to that title with Head Per Track (HPT) disk being one of the main features of that system, but including FORTE 2 on Medium Systems and ultimately DMSII on the Small Systems range.

After 2 years I moved to regional support getting closer to individual customer accounts and ran a team of 4 plus me supporting 6 Large Systems customers in the South of England and then various other pre-sales and post sales assignments with the final project lasting 16 years.

That final project was the Orange (now EE) Mobile Voice Mail system (VMS) and for the first two years of that I was the Unisys Test Manager ultimately ending my career as the Systems Architect.

In among the 36 years with Burroughs, which became part of Unisys, I did coding where necessary but always in COBOL, given one project was written in ALGOL the contract programmers working for the component that I designed received COBOL like “pseudo-code” from me which became 400,000 line of ALGOL. In addition I probably did the same amount of COBOL coding in my career and that excludes the coding done in FORTRAN before I joined Burroughs.

@John7 given the complaints I have made about DxO I am no apologist for them but I think that you are being somewhat unfair! Please see my comments earlier in this post and my OpticsPro 11 DOPs still work in PhotoLab 7!

@BHAYT I did some research. It’s a problem with win-version of OpticsPro 11. My build is 11.4.2, which is last one I think, and it tries to get modules from http link.
My friend has a mac-version build 11.4.3, by system log it connects to https.
Direct https links are working on both systems.

So, http-https redirect is broken at dxo server. Broken or disabled by reason.
And yeah, modules are the same. And could be placed manually.
/Library/DxO OpticsPro v11/Modules
C:\Users%USERNAME%\AppData\Local\DxO_Labs\DxO OpticsPro 11\Modules

Doesn’t seem to be a real solution, but at least something.
Regular backup of your existing modules folder would be a good practice.

(Earlier I backup my license files from user directory, so activation after reinstall is’t a problem.)

He can still use the software license, I’m guessing the license does not specifically cover getting lens profiles into perpetuity. Optics Pro 11 was released in June of 2016. It’s over 7 years old and presumably still works as well as did when it was purchased other than the ability to download additional lens profiles.


Got an installer for 11.4.5 (for Mac), installed it on macOS Monterey, launched in demo and downloaded the module…and it’s the same according to the checksum I ran against the module loaded from DPL5.

@equinox That is the same version as mine but I think mine is O.K., please take a photo of a wall and post it here or on dropbox etc. so I can try it.

This is OpticsPro 11 accessing a directory of files from late 2017 taken with my G80 and this is what I get

and after the download

So @equinox I don’t know what your problem is exactly because I am on Win 10 and it all seems as it should be for me!

@mwsilvers but I believe that the camera and lens are both supported by OpticsPro 11.

DxO has never, sadly, made any commitment with respect to allowing future cameras.lenses on “out-of-date” DxO products and I believe that is an accepted (by users) limitation, although not an entirely “valid” one. A disclaimer could be made that later camera/lens combinations may or may not be accepted on earlier DxO product releases!

An interesting experiment would be to add a later lens to an older database and watch the fireworks!

@platypus I guessed that would be true in this case.

This is Beyond Comapre after doing a full binary comparison on the modules in OpticPro 11 and PhotoLab 7 that have the same names, i.e. they are identical

But of course there are lots more new ones as well

Using OpticsPro 11 is like visiting an old friend but one I only ever used for JPEGs!

Go to your Documents folder for “DxO OpticsPro 11 logs” directory. Go further and open last log-file. Next - search for “download-center” to see, is link starts from http or https.

That’s even better. Even with recent versions of PhotoLab, I occasionally get errors when trying to install lens profiles. I had the same error “unable to connect to the remote server”, last week when I was installing a lens profile in PhotoLab 6. When I tried it again the next day the installation completed normally.