DxO Film Pack

Just another moan about DxO and their ways.
I have been using and loving this software virtually since it started, before it was Photolab. I also had DxO Filmpack Ver2, shows how long ago this was. Now I only occasionally use this so when I got a new PC installed it only to find I can’t activate it.
Support says Oh its not possible to activate it on Win 10, even though it runs OK, you need to upgrade at only £55 which is hardly less than I paid to upgrade to Photolabs 2
So guess who wont be using Filmpack again even though I have a perfectly functional copy

Film Pack v2 only works with 64-bit OS.
Why did you buy a 64-bit computer ?

It is a 64bit OS Windows 10

Regards Neil

Sorry hit the wrong key, It is a 64bit system Windows 10 I wouldn’t buy a 32bit system nowadays

I made a mistake too :frowning:

Film Pack v2 only works with 32-bit OS.
You have to buy a 64-bit release (FilmPack v5) for your Windows 10 64-bits OS.
This is the same rule for any software editor !

Can you use FP2 plug-in for PhotoLab2 ?


Brilliant idea tried Filmpack 2 as a plugin and if worked, activated properly, and is usable from within Photolabs.
So the whole " it won’t work with 64bit system" was rubbish
Thanks again