DxO fails to recognise CR2

I use FastRawViewer for culling.


The screenshot shows #-6192.CR2 and #-6192_DxO.tiff, the results of working on the file.

However,in Photolab the CR2 file is no longer visible, just the tiff file.

This has happened with a number of CR2 files.
I can see them in FRV, Affinity, ON1, Windows file manager etc - but not Photolab.

I have tried clearing the cache, deleting the database (thankfully I have no use for PL as a library, so no great hardship).

The CR2 files can be in any folder, can be ones I have never worked on in PL, or ones that I have done work with.

Using FRV, I send the CR2 file to PL, PL launches the image which is BRIEFLY visible before PL decides that it doesn’t really exist and simply shows me a blank interface and asking me to choose a file to open.

Using the PL library it is not possible to locate the file as this screenshot shows. The CR2 (#-6192.CR2) file is now invisible to PL though the tiff version is clearly visible.

It did this with one file last week (thought I had sorted it) and now again this afternoon with 3 files.
The file is still visible in FRV, Windows file manager, Affinity Photo, ON1 etc, so I am pretty sure it is problem with DxO PhotoLab

Anyone any ideas?


Win 10 Pro (64x)

Additional. Just deleted the .dop file and the .xmp for good measure and now I have the CR2 open…and a virtual copy available.

Looks like something to do with the sidecar files.


If you were to exit Fastraw viewer and PhotoLab, and then go back into PhotoLab, is the raw image now visible in the appropriate folder? What exactly do you mean when you say working on the file in Fastraw viewer? I also have Fastraw viewer and want to see if I can recreate the problem you’re having, but to do that I need to know exactly what you did.


Work flow is:

Open in FRV and cull / sort the basic files.
Open the chosen files in PL2 to do the actual work.

In each case where the CR2 file is not recognised, it is fine in FRV, but when sending it (via right click open with in FRV) to PL2 it briefly shows before vanishing and PL2 asking me to choose a file to open.
However, using PL2 the file does not show in the library and so cannot be opened from within PL2 itself.

The first time it happened I assumed a dodgy file.

It has happened half a dozen times in the last day or so, and the fact that the CR2 can be opened by another RAW editor like Affinity or ON1 suggest.it is PL2 that is the issue.

Deleting the database sometimes works and the CR2 becomes visible.
Deleting the .dop and .xmp files sometimes works and again the CR2 becomes visible.

By worked upon, I mean that these are files I have previously worked on in PL2 (hence the .dop file) and then decided to revisit and try a different approach.

So far this has not happened to any file that has not been previously processed in PL2. Hence my suspicion that it is something to do with the .dop files being generated by PL2