Disappearing image browser

I am using Photolab 4.2.1 on a MacBook Pro with an Apple M1 processor, running MacOS Big Sur. I have the problem that the image browser has disappeared.

More specifically, when I undock the image browser, I can view it. But when I dock the image browser, it does not appear at the bottom of the application screen or anywhere else.

I have tried different screen resolutions as well as external monitors and they made no difference.

The problem does not occur with DXO Photolab 2 running on the same machine. It also does not occur with DXO Photolab 4 running on my Intel-based Mac Pro.

1 Like

Hi Jonathon,

It sounds like the Image Browser is “hidden” somewhere/somehow … Try toggling Ctrl+F9

John M

1 Like

Try clicking on “Show/hide image browser” in the View dropdown menu.

Since posting the above I also installed the DXO Photolab 4 trial on another Intel-based Mac running macOS Big Sur, the same version as on my M1 MacBook Pro. The image browser could be docked and undocked without problems. Therefore this does seem to be a bug specific to the M1 platform; either that or my Photolab 4 installation on the MacBook Pro is corrupted in some way. (I would try uninstalling and reinstalling but I am wary of running into activation issues.)

I appreciate the attempts to help but I guess you guys are Windows users. The Mac version of Photolab 4 does not have the Show/Hide image browser selections in the View dropdown menu, and it is not designed to work with Ctrl key toggles.

I repeat that I do not have the Image Browser problem with Photolab 2 running on the same machine, nor do I have the problem with Photolab 4 on other machines. I hope someone from DXO will chime in …

1 Like

Hi @johnnyangel

I’m on Mac also. If we don’t have show/hide, you may (inadvertently) hide the filmstrip by dragging the upper border at the bottom of the screen.
Then it disappear, and doing Cmd+U make it appear separately and disappear again by Cmd+U.

You can put your cursor over the button of PhotoLab window until you see it changing to an icon with a bar and upper arrow which allow to drag it upper, and then once the space available is enough you should recover the filmstrip.

As I’m on Mac Intel this may not solve your issue and perhaps you already know this, otherwise it may be worth a try.


Je ne me rappelais plus de cette commande Cmd+U mais elle fonctionne parfaitement sur MBP en M1
I didn’t remember this command Cmd+U but it works perfectly on MBP with M1

Patrick, much to my surprise, your comment wins the day. I thought I already knew everything that you mentioned, and I had also tried connecting external monitors and changing screen resolutions, all without help. But, the solution was exactly what you described!

I’m really glad to know it wasn’t some M1-specific bug after all. Thanks so much!

1 Like

Happy to help. :grinning:

Bonjour Patrick, I too have the floating image browser and I cannot correct - I am an Intel iMac. CMD-U just causes it to appear and disappear but still floating. You stated …

You can put your cursor over the button of PhotoLab window until you see it changing to an icon with a bar and upper arrow which allow to drag it upper, and then once the space available is enough you should recover the filmstrip.

But I cannot interpret this. Is it the “main?” window or the image browser and what is the “button”.



Sorry, it’s not button but bottom!
I mean that if the filmstrip is not visible it may have been reduced totally.
Then putting the mouse cursor over the bottom of DPL window, when it change to double arrow, you click on this window border and drag it upper till you see the filmstrip again.

Merci Patrick and that’s not my issue. My issue is that the filmstrip is floating and I cannot see or find out how to attach it to the main window again. Attached.

Ah ok.

So you should drag your floating filmstrip to the bottom of the main DPL window.
And then it should go back inside DPL window.

Nope! That doesn’t work. I’ve resized the main window, changed workspaces -= just for something different but doesn’t work.

If you are on Windows then simply close the film strip and it will reattach itself to the main window. Sounds backwards but it works.

Ok, I thought it was that but not.
Just tried again, and Cmd+U attach or detach respectively the filmstrip from the main DPL window.

If, when you have the filmstrip detached in another window, using Cmd+U make it disappear only, then you still have to move the mouse cursor over the bottom of DPL main window until the arrow becomes a little bar with ^ . The you clic on the bottom border and drag it upwards till you see the filmstrip again.

If this does not work, then you could have a bug specific in your situation.

I’m on MacBook Pro Intel with Big Sur.

ça marche. Thanks Patrick. I’ll retain that info as it doesn’t seem intuitive to me. Would giving the option on CMD-U to permit re-attaching be easier? Or shift-CMD-U?

Merçi encore.

Thanks Keith but that doesn’t work on a Mac. I tried Dock but it just disappeared! BTW my wife and I, Canadians, love WA and have been there twice but had to cancel our third trip in 2021! Stay well.

Hi Martin, I hope you managed to solve your problem.

Next time you are in Perth give me a call and we can show you around and recommend some places to visit and specially for photos :slightly_smiling_face:

That’s very kind of you Keith and thankyou. My wife and I plus another friend were hoping to visit WA after a stopover in another favourite, Singapore in our winter 2022. Dunnsborough, Augusta, Albany and then up north to Monday Mia and Exmouth where we have old friends. Would have been our third trip. We did live in Sydney for 2 years 1992-4 where I was leading a project.

So next year while we can’t go back to Oz we’ll do parts of the USA southwest and northwest - great for photography!

Stay well.