DeepPrime XD weird artifacts

The first image I try, DeepPrime XD (with the options set to auto / default) seems to fail hard?

This is a crop from the tif export:

And then I just switch it back to DeepPrime without touching anything else, and it looks OK again:

Hello @jorismak Please, provide me with your original image and sidecar files. Upload them here with your forum name and let me know when ready

Dear @jorismak

could you please supplement your post with the description of your camera equipment you used and the operating system . Maybe that helps other users to save time if they have the same environment and know that Barbara is investigating this.
@all it would be very helpful if anybody with problems and creating a post will attach informations about equipment and operating system and version :innocent:

1 Like

Uploaded some files.

I’ve got it on every single file I tried so far. All files from’s PlayRaw section. One NEF (Nikon) file, one CR2 (Canon) file, two ARW (Sony) files uploaded.

On Windows 11 21H2, Intel i9 12900h / RTX 3050ti.

Hi @jorismak

I’ve tried quite a lot of my own files (CR3) with DP XD and didn’t run into any artifacts at all. I also downloaded a CR2 of the Victoria Memorial from but I can’t reproduce it on my Windows 10, i5-6400 and AMD RX480.

Do you have a direct link to the photo(s) you used? I’m curious if it is reproducible :slight_smile:

Since i have it on any file , it’s more likely a Nvidia related thing or something (since you’re on windows amd with no issue).

I uploaded the files to

That’s one i uploaded.

Found another :

@Barbara-S An (extra) notification to tell you the files have been uploaded.

But it’s clear by now that it’s not related to the files. I’ve got it on all files as far as I can see, no matter the brand / camera-model.

Also, when I go to the preferences and select CPU for the DeepPrime:

…then the results are OK. But exporting a single file takes 11 minutes, instead of +/- 14 seconds :wink: .

11 minutes? With a new i9-12900? I know it’s a mobile CPU, but even with my old i5-6400 I process a 25MP CR3 raw in 5,5 minutes.

Can your laptop dissipate its heat well enough?

1 Like

I redid the file, 1m52sec now. That’s way more usable until DxO (or me) get something sorted to fix the artifacts.

I might try forcing it to the onboard GPU, see if that works and helps a bit with render-time.

I guess it wasn’t plugged in, or I had it set to its silent profile or battery-saving mode or something.
Or something was still using power in the background, :man_shrugging: .

1 Like

Just under 2 minutes, that’s more like it :slight_smile:

With regards to your GPU, just asking the obvious: drivers are up to date?

With Intel Iris XE: 2m10s give or take. So that doesn’t give me anything compared to CPU only.

And I updated to the latest Nvidia drivers just after making the original post and checked if the problem was still there… it is. So yeah, at the moment I have the latest drivers.

As a Hail Mary I can try the ‘studio drivers’, but those aren’t really different, just a different release schedule in practice.

Good morning @jorismak. Yes we already got your files and will investigate.