DeepPrime XD not working properly with Ricoh GRIII RAW files

I get strange results with DeepPrime XD on my Ricoh GRIII files. See example below (the 1_Dxo file is the XD one, M_Dxo is the regular Deepprime).
There is some bad banding in the sky, and a purple color cast.

The regular DeepPrime performs okay.

An other very obvious example (with DeepPrime set to 11):

The color cast is one problem it seems some users are experiencing with DPXD. Are these very high ISO images?

Does the banding go away if Distortion Correction is turned off?

It behaves the same whatever the ISO (tested with ISO 5000 and 200).

You’re right, with Distortion correction turned off the banding disappears but the color cast is still there.

There are similar issues with Vignetting correction: Vignetting filter causing banding - DxO PhotoLab / DxO PhotoLab Windows - DxO Forums

The best way to address both problems - the color cast and the banding - is to submit a single support request via and upload some sample RAW files/sidecars referencing the support ticket # (use This will ensure that DxO’s developers will see the problem and identify the cause. They probably won’t give you a timeframe for fixing it, but if the problem is prevalent enough with Ricoh RAW files one hopes they will give it high priority.

I wouldn’t expect the banding with the vignette to be fixed as I had exactly the same problem a few years ago, uploaded files, examples etc. The outcome was, and still is, I use Adobe for lens corrections.

@stevvi it’s strange because it only happens with DeepPrime XD (or maybe it is much less visible with the regular deepprime).

@Egregius I’ve submitted a support ticket, wait and see!

I have the same problem with photos from a Sony A6400. A red cast is also produced in these photos when DeepPrimeXD is switched on during development.

@Jibz @stevvi @Harke41 As a test please try changing the Color Rendering setting from the camera-specific rendering to “Neutral color, neutral tonality v2” and then compare output to original RAW. Please note that this should be the only change you make. Use Apply Preset “No corrections” or “Optical corrections only” and export, then after this change the color rendering as described above to the exported file to accomplish this. Does this help?

Picture with DeepPrimeXD


No, it didn’t help. In my opinion the processing by DeepPrimeXD causes the error. If I develop the photo with DeepPrime, then the colors match. If I use DeepPrimeXD, a magenta stitch is created. See attachments.