Cropping in 3.3

I have noticed that ever since upgrading to 3.3 Build 4391 that sometimes when I want to crop a new image the crop rectangle is not there. Usually pressing the Crop Reset button displays it but other times I’ll have to actually use my mouse to draw and define the cropping rectangle before it appears.

Is it just me or are others seeing this too?

Thanks for any responses.

Hello @JohnZeman,

It means that your Crop correction is set to “Manual” instead of “Auto based on keystoning…”. Please, double check.

What preset is set in preferences by default?

Svetlana G.

@JohnZeman, it sounds to me like you have the Crop switch in the Geometry palette (or a custom palette) turned off. So when you turn on the crop tool above the image viewer, you’re not seeing the crop rectangle. Is that what’s happening?

In the past, I’ve expressed my wish that turning on the crop tool would also turn on this switch so that you can adjust the crop rather than have to draw a box or go to another part of PhotoLab to turn it on there, too. But for RAW files at least, I use a preset that keeps Crop on in the palettes.

Ah, thank you for that Svetlana. I must confess that I hadn’t looked at the actual crop palette while cropping, I just click the crop tool in the top toolbar to crop so I hadn’t seen that option until you pointed it out to me.

I use a variation of the DxO Standard preset and indeed the crop tool options in my preset were not enabled.

Thanks again.

1 Like

Thanks for your reply too Egregius, I was answering Svetlana when you responded so I missed it at first. And you are right, what you said is exactly what is happening. I had totally missed that option until you two pointed it out to me.