Create option folders not being saved to

When you create

  • the “New Folder”
  • rename it straight away within the process, e.g. to “Garden”
  • and confirm with OK !!

then after restart, PL will remember your last Custom folder, e.g. “Garden” in this case .

Hope, that helps.

That’s what I have been doing and its never always worked. With V5.1.2 its changed and when it doesn’t open in the created folder (most of the time it’s not now) it has a “New Folder”, shown in the Path to save too. Then I used to be able when seeing that go back to Browse For Folder and move to the folder I created. After saving you would find a empty New Folder created by PL and delete it. But with 5.1.2 its not creating the New Folder so when you Browse For Folder you don’t go back to the root (my “Test” folder) but the next one up, Desk Top”. There is no New Folder being created now which is making even more work getting back to the created folder. I remember this as a problem going back to PL1.

Its doing this on my desktop, laptop and my wifes PC using PL2.

John, I’m on the latest (Windows) PL

and can determine the target (Custom) folder

Thanks, that works and I will try uing it. But this is a workround for the creat new folder option not working properly. DXO need to get options that are given working as they should, as these are the options most users will use rather than workrounds to over come there short commings.

Well, the first option is the very same like with Windows’ explorer, where you have the chance to rename the standard entry “New folder” straight away – so nothing special.


With PL, just don’t rename it ‘outside’ of PL.

The PL option using Browse For Folder allows you to create a new folder, rename it from New Folder then clicking OK creates it. The problem was it at times created both a New Folder and the renamed new folder. It than add either to the save to Path. If saving to New Folder the one renamed will be created as well and you could move the save Path to the renamed folder away from unwanted New Folder. This unwanted New Folder afterword’s has to be deleted.
With 5.1.2 its appears PL is not creating the New Folder even though it shown on the save Path. So if you go in to move the save path your renamed folder you end up out of, in my case Test folder, and back at the Desktop one and have to go back into the Test folder to go to the folder to save to. Its basically PL file management doesn’t interact correctly with Windows and this goes way back They sorted, after for a long time denying there was a problem, of dop’s not all being deleted when a images was deleted in PL. That side to miss handling was sorted only when Svetlana took it up and it was finally admitted there was problem (bug/s)by support. I suspect this folder creation/saving problem is tied into the same problems that related to the dops not being removed properly.


Using the work round of directly adding a new folder name to
Screenshot 2022-01-21 093728

Rather than using Creat New folder works every time. BUT this is a work round and shows the bug is in the creat New Folder part of creation and saving in PL. Is there any prograess with this?

This looks like it might be different from Mac to Windows.

On a Mac…

Capture d’écran 2022-01-21 à 13.57.19

Capture d’écran 2022-01-21 à 13.54.56

Capture d’écran 2022-01-21 à 13.55.09

There is no option to rename a folder whilst creating it as the name is typed into a small dialog and that is added to the target folder. The only way to rename it would be in Finder.

The full process that in Windows which has the all to high failure rate to add the created folder to the actual save path is click on Export to Disk
Screenshot 2022-01-21 144839
Which brings up the save to options which includes
Screenshot 2022-01-21 145047

at the end of Path is a folder shown that opens up
Screenshot 2022-01-21 094100
From this you can create a new folder and rename it. It should it add the newly created folder to the end of the save to path but its unreliable. All to often it adds New Folder to the path, and you find if you forget to check befor saving you have saved into the New Folder and your renamed new folder is created, but empty there as well.

The workaround is OK when saving to new folders within an existing path, if you want to change that you have to go back to the create new folder and hope it works. This has been a windows problem for years, I get it on 2 laptops and a new tower. For me it’s a pain as I save processed images to see how well they have worked and take them from there.

That’ll be the equivalent of clicking on the folder drop-down and getting…

Capture d’écran 2022-01-21 à 13.57.19

… which then leads to the folder choice dialog where you can only create a folder but not edit its name.

What you’re finding looks like a very poor Windows routine, which may well be bugged.

I’ve been bagging away about the poor windows interface programing for a long time. Some of the bugs have been fixed, failing to remove all the dop’s when deleted in PL but folder creation which I am convinces is linked to the original poor programing is getting nowhere. I have never used a program that miss handles folder creation and saving as poorly as in PL!

No problem here.

As said, one has to rename the standard entry “new…” straight away.
Doing so outside of PL does NOT change the registered path, but remains → “new…”.

Similar case, when to rename a folder with pics and sidecars, do it within PL’s Library.
Screen Shot 01-21-22 at 02.40 PM

1 Like

It not the renaming it’s the newly named folder being added to the save to path that often missing. Naming had never been the problem. I have also never created folders to be saved to out side of pl

Hi John,

I’ve noticed your post has been going for quite a while now - but, to be honest, I’ve never really understood your issue/problem … other than PL is not doing something that you want it to do (?)

Can you please explain the end outcome you’re wanting to achieve (without going thru the detail of what you’re trying to do). That may then help us to offer a solution - and/or, to understand your problem.

Regards, John M

When folder is created in creat folder it’s added every time to the save to path in place of most times but not all. To prevent when that happens your save going to a new folder and the named one you add left empty.

Mmmm - It seems to work fine for me.

Why are you creating a new folder (from within PL) ?


1 Like

If I may add - why are you renaming new folders (from within PL)?

I export to test images and load them onto some Facebook sites. To make it easier they gointo s folder named as the raw folder is. But the options are there in PL and should work properly if there, it shouldn’t require me to justify why I am using them!

We are not asking for justification, just a better explanation.

If you are claiming to have found a shortcoming that nobody else has found, then I would suggest that whatever you are doing is going against the accepted way of working the everybody else is using. And, so far, you haven’t been able to concisely express what you are doing, in such a way that anyone else can reproduce.

Any explanation has to be exhaustive, step by step, with screenshots at every stage and comments explaining exactly what each and every step involves, including why you are doing it; if you are ever going to hope for a solution.

You have never explained what both the source and destination folder hierarchies are or, even if they are on the same disk.

Post 25 went through what I am doing (as have others) and that time a screen shot of the save Path showed it ending up with New Folder not the created Garden one. The test folder is on the desk top so drive C. All I do is use the provided creat new folder option in PL under Export to Disk frustratingly I do nothing odd like use a removable disk (though PL should cope with that as well) just use a save option with in PL. But this is a problem on this, my laptops and was existing years back on an old replaced laptop as well (probably pry PL). I was told DXO was going to look into it, but never have