Crashing on open

Just tried to open photolab after some time without using it, and I’m getting immediate crashes on open. A crash report popup comes up, but it closes to before I’m able to send the report or copy the code. Never had issues before. I’ve downloaded and installed the latest version too.

I’ve also uninstalled a installed the supposed ‘hotfix’ that appeared on another thread last week and I’m still getting a crash.


Please, address the issue to the support team - and provide them with the logs ( Log files – %UserProfile%\Documents\DxO PhotoLab 2 logs)

Svetlana G.

IT sounds like you are running windows, can you confirm? and which version? Knowing your system specs might also be helpful.

Grab the logs and forward to the support team as Svetlana has requested.

If you are using windows and your system continues to run after the software crashes of fails to start, you can find more information about the problem in the system event viewer. There should be an entry which correlates (date and time) with a failure.


The more information you can provide support and the community, the faster you can get your issue resolved. Focus on Svetlana’s request first.

1 Like

I’m on Windows 10. Submitted support request with logs now.

1 Like

Good, thank you!

I’ve submitted crash logs to support but so far all I’ve gotten is to make sure I’m on the latest version, which I am. Anywhere I can download older versions to test?


I have every build of PL for windows since v1.x

This is the latest final release from DxO (Windows)

!! Link edited by moderator !!

Here is 2.3.0_23891 from my archive if needed

That version is still carshing for me.

At the moment, you are the only person who continues to have a problem I am aware of.

None of us were having an issue with 2.3.0_23891 (Program crashing)

So at this juncture, Its probably safe to say something in your environment is causing the problem.

What is the last version of PL that worked for you?

If you have submitted a ticket, your issue is likely being looked at.

You can certainly request an update.

Or most likely, the version that made everyone crash (which was the first one I had issues with) corrupted something in my environment, as I never had issues before. Have tons of other software, game and programs and none of them are crashing. I’ve been working with support for 3 weeks now without any advice on how to repair the installation other than installing the new version. So, any other idea of what directory or settings file I need to delete to avoid this?

Best recipe on Windows to have issues…

I’d start with a new user to at least have a clean user profile. This way you can rule out that anything left behind by previous runs brings problems.

Then I’d separate my environments for games and serious work by starting with a fresh Windows installation on another partition or drive similar. No idea how you do that nowadays in Windows.

Hello @flowerdealer,

1 - Could you, please, check if you have “vcamp140.dll” file in this directory - c:\Windows\System32
2 - Could you, please, attach the crash logs here and I’ll have a look at them.

Thank you,
Svetlana G.

DxO.PhotoLab.txt (64.9 KB)
Vcamp140.dll is indeed present. Splash screen is crashing before it can get to crash reporter.

I’ve finally narrowed down the issue. I have MSI afterburner installed for gpu monitoring. As long as any GPU monitoring is enabled (gpu temps, for example), DXO crashes. Never had this issue before and I’ve always run MSI afterburner and never had this issue. Don’t have the issue with any other game or software either. Thanks for your help. Workaround for now is to disable monitoring.

1 Like
  • Yep, there is nothing about the crash in your logs :frowning:
  • Cool, that you found the cause of the crash. We’ll have a look on the behavior when MSI afterburner is running.

Svetlana G.

Hi - FWIW, I started having this same problem a day or two ago after installing the latest minor Windows 10 update (computer needed to restart). PhotoLab 2 reports a crash while the splash screen is still up, and then everything is covered over by the main application window, opened fullscreen but completely unresponsive. I opened support ticket #190161 to report the following:

  • The symptoms of the crash since updating Windows.
  • Running sfc /scannow reports errors that couldn’t be fixed.
  • Running dism repaired errors.
  • Running sfc /scannow again reports errors that have all been fixed.
  • Still, the problem persisted until I reinstalled (repaired without first uninstalling) the latest PhotoLab 2 downloaded from the store. Now it seems to be stable again. Keeping an eye on it.

This is the first time in years that I’ve had any such issue.

Hello Greg,

Thank you for the info. It’s good that you opened a support issue. In the meantime I will update my Win 10 to check.

Svetlana G.

We officially don’t support side by side work with software that hooks the graphic driver. Below are examples of such software:

  • Riva Tuner
  • Asus Sonic Studio
  • MSI afterburner
  • Nahimic
1 Like