Control points all have the same settings

I can make a CP like in V2 and it shows the expected mask, but it changes the entire image, or at least a large area. When I try to place a neutral/negative CP near it with neutral settings, that point keeps the same settings. Help!

Dear @Dianedm ,

on Windows 10, DPL5, Viveza 3 for me it works

Could you please supplement your post with the relevant informations

or is your selection to big, Please choose a setting of 1:8 view and take a look where the outer circle is


@Dianedm, to also pick up your question from U-Points setting - #2 by Joanna

Unlike ColorEfex 4 – Viveza 2 and 3 have no specific negative control points. Instead you have to use another control point.

In Viv2 it was quite simple to see the constraints of the ‘negative’ control point in the mask view, but very unfortunate (!) that’s no more the case in Viv3. The effect is still there, maybe to a lesser degree.

→ Have you ever tried the Chrominance and Luminance sliders to fine tune the selectivity of the control point masks?

I’ve made a second CP with different settings and it works like expected

The brren and red settings only for demonstration…is not my normal workflow :sweat_smile:

@Dianedm Take a look here Portrait Editing in Affinity Photo & Nik Collection Viveza 3 - YouTube

Thank you, Wolfgang! I finally found a video about Viveza 3 – all the others I can find are about Viveza 2. I now see that I can refine the selection area with the Chrominance and Luminance sliders, and that has fixed the issue I had.

Something else may have been going on, as the selection was not large but the adjustments were extending well across the entire image, and if I created a second point with no adjustments to try to constrain the area, it was linked to the first one with the SAME adjustment. Then the next day, after I found the video, I tried again and I the luminance and chrominance sliders fixed the issue. I will go back and see if I can now make two independent control points. The behavior I had was very buggy.

New M1 Pro MacBook Pro, OS 12.1. I’ve had other strange issues with the Wacom Intuos tablet and I wonder if this was another issue with it? (I did upgrade its driver with a fix.)

I’ll post again if the issue persists or seems buggy.

Take a look at the video and take a closer look at the terrible UI


With the new masking tools in Lightroom and the Tony Kuyper luminosity masks in Photoshop, I will have less and less use for Viveza. I loved it for masking but I’m frustrated with where it is now in development.

Hi Diane,
I keep using Nik 3.3 for old PS, which doesn’t support the newer version.
About the Wacom Intuos tablet, DxO’s support could be so much better for a ‘professional’ software.

And Guenter colorized the selections, so that they are visible for you.
→ Colour Selection → Picker → Colour swatch