Change of Presets in DxO PhotoLab 6.7?

Something seems to have changed with the presets in PhotoLab 6.7:
I edited an image and first used the “Perspective” button for an automatic correction. PL rectified and straightened the image perfectly and cropped the edges to fit. After that, I just moved the upper and lower edges a little with the crop tool so that a few more details were included at the top and bottom of the finished image.
I usually do these steps first, because otherwise there may be shifts in the “local adjustments” that may be required.
I then applied the High Dynamic Range (Single-Shot HDR): 1 - HDR - Realistic preset to the image. After that, my automatic perspective correction and cropping was completely changed. It really shouldn’t be. So far, this preset has only influenced tone and brightness values as well as contrast and color accentuation. I had to undo the change and then manually enter all of these values so the perspective and crop weren’t touched.
I must stress that I have never created my own presets or made any changes to the existing ones. These are the original presets supplied by DxO.
I haven’t tried any other presets yet.

My system is a Windows 10x64 pc. I don’t know if this also happens on a Mac.

I only have the V6.5 with me now but there is not this problem.
I will try on the V6.7 as soon as possible.

Yes, @Franky, up to version I didn’t have this problem either. With 6.7 this is completely new for me.

I tested with the V6.7 and I don’t have this problem.
I compared the preset files, they are identical

I followed that step on winnows PhotoLab 6.7.

I did that as well, but I see no changes to the perspective or crop or anything, just tone and color change.

Yes. For me that is how it still works.

I don’t know if its a bug or something else, but as far as I can see the original presets that ship with DXO have a little lock icon, so they cannot be edited.


I can however copy the original preset to a new preset and than I can modify the settings by simply right mouse click and choosing EDIT on the preset name. In the tools panel there will various options one can check or un check.


If you can’t solve it by other means and you need to use that preset, this could be a temporary workaround.

But I wonder if there are some other settings somewhere causing the undesired change.

One thing to check is… to make sure something like Auto Crop is not turned on… that is is you want to crop manually off course.


Other than that, outside the bug I’m not sure what it could be.

@Ralf_Brinkmann Can you share your preset that is problematic to compare it ?

The Preset-File itself? Of course I can do that. I hope I do it the right way.
1 - HDR realistic.preset (1,8 KB)

Your file is identical to mine and works normally.
I could only try on the V6.5, I will try on V6.7 when I get home

I try to upload some pictures to show what happens:

1.) Image set back to standard preset.

2.) After click on the perspective button (automatic correction)

3.) After using the crop tool to add a little more space at the top and the bottom

4.) After clicking on the preset “1 - HDR - realistic”

Are you on a virtual copy, is it also done on the master image?

Here you can see a little better what happens:

Here the crop tool is opened after the automatic perspective correction. I’ve moved the top and bottom lines a little bit to the top and bottom edges to show as much as possible of the motorcycle.

Here the crop tool is opened after the next step, the click on the HDR preset. You can see that the geometry has completely shifted.

Yes. I just didn’t want to destroy my original result, but usually I do everything on the master image.

Of course, it was to investigate, I will try it when go home with the V6.7

I just tried and I think I had a slight modification of the crop by applying the preset.
But I can’t reproduce it.
On the other hand, twice PL closes as soon as I try to move the reshap.

Once you see the problem, look in the history what has been changed when you apply the preset

Hi Ralf,
without having tried your preset (yet).

My first idea was the ‘original’ length to hight relation to be the culprit,

  • but then noticed the first pic showing up with distortion applied,
    while the second one doesn’t have it.

  • Maybe also uncheck (manually) “Auf Bild beschränken / Constrain to image”
    to see if it makes a difference.

I just tested it with PL6.7 on a W10-64: no problem at all.

I think I need to experiment a little more as to why this is happening to me. With different images and different presets. I’ve never noticed anything like this in all the years (including DxO Optics Pro). However, I don’t use different presets every day to try things out, but usually only use the standard preset. I’ll have to report back if I’ve gained further insights or come across any oddities.

Looks like distortion correction has changed…and this will also change crop.

I usually default my crop settings to manual and unconstrained and switch to auto on a per image basis. This helps to include more of an image, but a few cases resist and need manual adjustments like shown below. Nevertheless, changing the preset does not change the geometric properties of the image (macOS Sonoma beta on M1 MacBook Air 2020)

@Ralf_Brinkmann , I checked the preset. It’s a DPL standard, partial preset which does not change crop or anything…but in your screenshots, I find that you’ve checked “Auf Bild beschränken” (Distortion tool) in one case, but not in the other.

I found something out now and it may be the same as what you mean. I tried different presets and they all had the same distortion.
I noticed that under “Distortion” with the standard preset (i.e. immediately after opening the image or after a reset) under “Limit to image” there is no check mark.

However, after each application of any preset there was a tick in it and triggered the changed distortion. If I remove the tick again, the previous, desired state is restored.