**Catastrophic** performance issue with "Fix image path"

I don’t think that first word is over-stating the problem.

I opened some projects in PL5, most of which had been created under PL4 and migrated. Some of them had the dreaded ? image thumbnail. I am quite sure some of them have never been moved but perhaps I am wrong on that score. In any case, I know how to fix it.

So I selected one image (the option is curiously not available if more than one image is selected) and chose to Fix image path… This is where things get bad. Really bad.

If I chose a project with 25 images it takes considerably longer than I would expect, but so be it. However while it is linking them up the entire computer is responding very poorly. If I leave it alone it gets the job done and eventually the thumbnails appear.

But look out if I choose a project with too many images. The entire computer eventually locks up to the point where the power button is the only recourse. I don’t know where the limit lies. I tried 50 and took even longer than 25. I accidentally* tried 116 and it did work after an extraordinarily long time (something in excess of 10 minutes). I accidentally tried 136 and the computer locked up again.

On the first lock-up occasion I went away and left the computer for over an hour and it never recovered. And here’s the fun part… if you have to Force Quit the app (assuming you’re lucky enough to get the Force Quit menu to display) or power off the computer, none of the images already relinked are remembered! On that last point, I carefully moved images around between real and temporary projects to do only 25 images at a time and succeeded in getting several hundred images relinked but then accidentally set it going on the 136 and after I started the computer back up and relaunched PL, all of those hundreds of relinked photos were stuck at ? again.

As a further result of that last crash, I now seem to have not only ? thumbnails but PL has lost track of which images they even were, so I now have to go and locate somewhere over 200 photos one by one again, using an external reference I am lucky I have.

REALLY not impressed by this. It’s not moving files around. It’s not processing pixels. It’s simply matching up file names. There has to be something seriously, seriously wrong here.

I also noticed that only a single CPU core is being used so the locking up of the computer doesn’t make sense unless PL is locking the main thread.


Of course having put all that in writing I closed PL and restarted it a couple more times and things have changed slightly. Which is also concerning.

On the first re-open post boot, in fact only the first 25 images of the 229 image project were without file names. Upon another restart of PL, they all have names and… this is the weird part… the thumbnails are present! Well… most of the thumbnails. Curiously about 50 of them are ? still but they are scattered throughout the project so not representative of the groups I was moving around to get around the performance issues.

At least the other albums seem to be OK and not, in fact, regressed. So I’m happy that there is less work to do than I thought, but it’s still a huge drama when it should not be.

1 Like

I’m also experiencing this issue.

  • I’m finding projects with broken image paths for all, or only some, images, without any manual management of underlying filepaths
  • The only way to fix this is to fix image paths one at a time (?? apparently)
  • Attempting to do so for a single image immediately causes the app to hang

DxO 4.3.3 – MacOS 11.2.2

At least in PL5, and I think the same was true of PL4, it seems like it will only do one but given enough time and no total system hang or crash, it will in fact re-link the entire project’s worth of images.

The problem seemed to occur due to the number of images for some reason so what I did to work around this was create a separate project with around 50 images and do it from there, as that seemed to limit the scope.