Can't update to PL5 (v5.15.1,) "can't create necessary temporary."

Presently using PL5 Elite 5.15.0. I have successfully downloaded the 5.15.0 to 5.15.1 version on my Windows 11 (lastest version.) However, when doing the install, I’m getting the error message that a necessary temporary file can’t be created. The install will still continue to Finish, but PL5 still shows its original version (5.15.0). I have tried opening the install exe with Open as Admin, to no avail. Thanks.

This is the sort of thing tech support needs to work on with you one-on-one: Hope you get it resolved.

Not waht I want to hear, bu thanks for your input.

Have you tried to download the full installer from your shop account and do a reinstall instead of an update?

No, I haven’t. Sounds like that could be fix. But, I’m not sure how to do it. I would assume that I would first uninstall the present PL5, but after that how do I reinstall PL5? Thanks.

First try installing over the top of your existing install. If that does not work then uninstall and try again.

I would do that, but I can’t find a link to dl PL5 v5.15.0? I do have a registered activation code that gets me the Elite edition.

Login to your account on and go to My Software and download from the link provided. You will only get the latest version you are registerd for.

If that fails then contact support.

That failed miserably. When trying to install from a DXO site the first time, got the error message that “C:\program files\DXO” couldn’t be made. I then made the folder “C:\program files\DXO,” but that wasn’t acceptable, and the program didn’t load. The next time I tried to load the program, I got an error message that “C:\program files\DXO\DXO Photolab5” couldn’t be made and program failed to load. I now do not have PL5 Elite on my PC and will continue to let DXO support know about this terrible change in events.

Sounds like permission problems in Windows!

Try running the install as Administrator.

Thanks, but running as Admin made no difference in the error messages. I now don’t have PL5!

I have notified DXO and they have asked for log_log and bootstrap log_log files…which I have just sent to them.

EDIT: Another fly in the ointment. Using Everything, I found that I still had a working PL5…even after I thought I had deleted PL5. However, this PL5 was version 5.12…an older version that had already been updated. Anyway, it is working, but it, also, throws that same errors that 5.15.0 threw when trying to update to 5.15.1???

No need to go any further. The error was due to Window’s enhanced Ransomware protection (Error 1317, Error: 1317 during installation | Crick Software). In order to prevent suspicious third party entries, Windows added a Controlled Folders Access button. With it ON, it will stop malware from overwriting, or forming files/folders. When I turned that function OFF, I was able to update Photolab 5.12.0 to 5.15.1 without any problems. Of course, after the update, I immediately turned CFA back ON.