Can't open DOP file when watermark definition cannot be resolved

Tried opening the DOP file on my Windows PC (latest PL version 4.1.1) from this thread.

I get internal error. After some tries I deactivated the watermark, then the image can be rendered.

I assume there is a better way to display an issue like this to a user.
A more descriptive error message like “Font for watermark not found” or “Error resolving watermark definition” should help a user to find the problem easier.

Hopefully Joanna, or someone from DxO sees this. It’s a “text” watermark from DxO, but maybe the font I selected is confusing your Windows PC? That’s the only thing I can think of. Can you try it with one of my other images, with a different watermark?

I did get my Lenovo W530 Windows laptop running, but I don’t think I can install PL4 on it - licensing issues. I do have an old, purchased, copy of PL3 - or I can install a trial version.

This makes no sense to me, as once the watermark is embedded into the image, the next computer shouldn’t need to have that font installed. Maybe I just need to leave the watermarks off the image when I upload to this forum?

It is most probably the font you used on your Mac, missing from my default Windows install.

I don’t think you have to do something with your files.
It is definitely the software that should handle such cases more efficiently, instead of giving a cryptic error message.
It is not the most usual case to transfer dop files, but it is also not forbidden.

As it is a be text watermark, it is rendered at export an there the font is needed.
I haven’t tried it with a picture watermark, I leave it to the Devs.

A few days ago I experienced the same issue with another of your files on my PC. After several tries, I settled on the same solution reported by @bekesizl . Probably, it is better to deactivate the watermark before posting the dop file.

Regards, Joseph

I won’t post anything from now on with a watermark.

Thanks, and sorry for the confusion…


Interesting, because I went to use my standard watermark via my preset the other day — since I had done some housekeeping on my SSD — and it could not find my CC license image. It did not stop anything rendering except that part of the watermark.

Maybe the Mac implementation is more tolerant.

Nonetheless I consider this as a bug.

Let’s assume I get a new computer, transfer my licence and files and forget to install that special font, because I used it some time ago, but not anymore.
I revisit a photo for some reason and PL can’t open it saying “internal error”.

If you are tech savvy enough, you might find the problem, but a better error handling would be nice. Either ignore the non existing font or display a descriptive error message.

1 Like

Good morning,

Yes, the error is displayed because the font is unavailable. But I agree, the message is not informative. We’ll see if we can better handle it.

Svetlana G.