Cannot view "Getting started" videos. (This video is private)

Hello, as this is a forum, first a small introduction. My last “proper” camera, was a canon F1… . For a few months, I’m happy with my first APS-C mirrorless. Since yesterday, I’ve been trying out PhotoLab Elite. When I tried the noise reduction, I… (regular users can picture someone trying it for the first time).

When I visit one of the pages with a “Getting started” video, instead of the video I see the following message: “Because of its privacy settings, this video cannot be played here.”

I find watching even the most basic videos can be helpful. (Even if all the information is essentially included in the manual)

Has anyone else had this problem with the embedded vimeo videos or is there perhaps another way to watch them?

Thanks in advance.

Hello there and welcome.

Are you referring to these videos?

I tried all nine and they work fine for me,
I’m not loged into any account anywhere except to the DxO forums.

Check your privacy settings on your browser.

1 Like

Spoof [HTTP referrer] string of third-party requests
which makes sense as this probably prevents vimeo from knowing that I’m trying to watch the video on the dxo website.

I can see all the videos now. Thanks.