Can you Rename Keywords in PhotoLab 5?


I have searched the forum for an answer to this and have not been able to find anything. I have set up a number of Keywords in PhotoLab 5 and assigned them to various photos. Even though a Rename option is available, it doesn’t seem to work. If I right click on a keyword, one of the choices is ‘Rename’. When I try to rename the keyword it shows up in red and doesn’t accept the change. Would the renaming of a keyword need to take place before it is assigned to any photo, or does the rename option not work at all?

When I rename keywords in the keyword list, the change is reflected immediately in the keyword tool:

  1. Initial keyword hierarchy

  2. I change one of the keywords (no matter which hierarchy level):

  3. After hitting ENTER, the change is applied:

One thing must be considered though: While the keyword change takes place immediately in DPL’s database, MD in the .dop and .xmp sidecar files will be updated or not, depending on DPL’s setting.

If automatic MD updates are disabled like shown below…

…sidecars must be updated manually, through DPL’s file menu. If sidecars have not been updated, the changes will not be visible in other applications and/or can be reset, when MD is read from the file(s) again.

Note: I’m on Mac

1 Like

Thanks for your answer!

Unfortunately, it is not working for me. When I try and rename a keyword, it highlights in red and won’t save.

Original Keyword

When I try and rename it

After hitting enter

I guess I will either have to live with my misspelling, or open a ticket

…you could edit keywords in DPL’s database…

Is that something you’d venture into?

I think you’ll find that is because the “keyword” contains comma delimiters, which are not allowed in a single keyword, because that would make it into three keywords.

If I try to add your misspelt list of words (because that is what it is) to the dictionary, that won’t be accepted either…

Capture d’écran 2022-07-16 à 13.48.42

I am guessing that you used some other non-standards-compliant editor to add the keywords in the first place. What did you use?

Addenda for Mac

I just used ExifTool to force a keyword that contains commas into a file and then read it in PL…

Capture d’écran 2022-07-16 à 14.03.48

Then I tried renaming it using the inline editor rather than the context menu dialog…

Capture d’écran 2022-07-16 à 14.04.00

When I pressed the Enter key, I got a most peculiar message…

Capture d’écran 2022-07-16 à 14.04.11

Not exactly what I would have expected. I am guessing somebody reused an existing dialog instead of creating one specifically for this use case @StevenL

1 Like

I would venture into that. I just have to figure out how to do it. Thanks

I originally added the keywords directly in the inline editor. It let me have commas in the keyword when I first set it up.

I just tried entering all 3 words without commas, and it let me rename the keyword. Thanks for your help!

In actual fact, you need to be totally confident of what you are doing as getting it wrong can screw the whole database and, if you also use projects or persistent history, or you don’t use DOP files, you could lose everything for all your images.

There are a couple of external tools that will help - are you on Mac or Windows?

Yes, but how did you get the keyword with commas into the files in the first place?

When I added the keyword in the first place (with the misspelling) it let me put the commas in, and no error message at all

May I ask why users need to prevent the traps set up by apparently highly competent programmers? What @bphillips was doing with the commas is rather standard. And if the software doesn’t refuse to save them, I tend to believe “I haven’t done anything wrong”.

Hmmm, that’s worrying. You mean you did this in PhotoLab? Do you know which version?

The problem is that the Mac version does refuse to save them. So, is this yet another Mac/Win difference? If so, this is pretty serious because having commas in “single” keywords is a definite no-no, as all keywords get saved to comma-separated lists and it can make it difficult for other software to discern whether it is finding single or composite keywords

Yep, I set up the keywords with the commas in PhotoLab. I run Windows and have PhotoLab 5, the most updated version. I’m not home right now so I can’t tell you the exact version number, but it is the most recent one


Since it isn’t possible on a Mac (and it shouldn’t ever be), I would say you’ve discovered a bug - or, at least, a very undesirable behaviour that makes PL incompatible with all sorts of other DAM software.


I’ve tested renaming in the database and it worked in my tests. The things I did should work with DPL on windows too, but I cannot test it.

I managed to add commas to keywords in the DB without unwanted consequences. Also, the “comma-fied” keyword could be changed in the keyword list.

After editing keywords in the database

After editing out the commas in DPL

Indeed editing out the commas would not pose any problem.

My initial impression was that Beth wanted to correct one of the words whilst retaining the commas, which, on a Mac at least, isn’t possible.

Is there anyone else watching this thread, with a Windows machine, who can confirm if it is possible to enter a " keyword" that includes commas?

I launched PL5 pointing at a test directory that contained one image - previously processed so the directory contained the RAW .NEF file and the associated .DOP. At this point the image, and indeed the Pl5 database, contained no keywords.

I then added a Keyword that contained several commas - see below - which was accepted with any problem.

I then added a second Keyword, again containing several commas

I then copied a second image (.NEF and .DOP pair) and applied the two multi-comma keywords to the new image without any problem.

I then tried to Rename one of the multi-comma keywords, to a new Keyword that also contained commas. At this point PL5 objected, highlighted the unaccepted Keyword in red and just retained the original Keyword. Unsurprisingly, when I tried to Rename the multi-comma Keyword to one containing no commas this was accepted without any problem.

So it looks the validation Joanna is expecting is applied within the Rename code but not at the point of initially adding a new Keyword.

1 Like

I’ve just flagged this topic as a Windows bug. Hopefully it gets some attention.

Could you post the XMP sidecar file here?

Here’s both of them
2022 06&07 #1 - Digital RAW-168.xmp (3.2 KB)
2022 06&07 #1 - Digital RAW-169.xmp (3.2 KB)