Can I run PhotoLab 3 and PhotoLab 4 side by side peacefully?

Must I uninstall PL 3?

1 Like

No you don’t have to

You can run different versions of Photolab side by side without them impacting each other. They are completely separate installations with their own database and own data cache. I run Photolab 4 and PhotoLab 3 on my windows machine. If I still had Photolab 2 installed I would be able to run that as well.

One of the things that I’ve always liked about Photolab is that the installation of a new version does not overlay the previous version or share files with the previous version.

Keep in mind that uninstalling a version of Photolab in Windows doesn’t uninstall everything, which is unfortunate. If you are using Windows, and feel comfortable going under the covers, I can tell you where these unremoved folders are located and you can delete them manually.


I’m running PhotoLab versions 2, 3 and 4, no need to uninstall except for gaining some drive space.


  • .dop sidecar files are not fully interchangeable between different versions of DPL.
  • One way: Higher versions of DPL can read and understand sidecars from older versions,
    the reverse is not necessarily the case.

If you want to work with several versions of DPL

  • Make sure to disable automatic import and export of sidecars.
  • Uncheck the respective boxes in the last tab of the settings.
  • Be careful when you export sidecars because of the interoperability cautions above.

As @platypus wrote dop files arn’t interchangable between versions.
From v3 to v4 means it’s rewriten, upgrades to v4 so from that moment v3 has a problem with settings which arn’t available in v3. Toolsettings which v3 don’t have like deep prime.

So if you set for instance v3 as no read and write dopfile’s thus only database then you don’t run in to trouble.
If v3 dopfiles are read by v4 it automaticly update’s it if you have write active and click on the image.

I checked this as soon as I installed PL4, and I confirm this. Whenever I touched a .dop file with PL4, PL3 would not be able to read it again.

It is very understandable that PL3 will not be able to do anything with the settings specific to PL4, there is no way it could be different.

But still, I wish that PL3 could read the settings that are common (e.g., star rating, resizing, horizon, …). I can see cases where someone would start working on a raw file with his copy of PL4 and pass it to a someone else who has only PL3.

That’s really odd that you should find that. I just took a file that had been treated with PL4 (including some PL4 only tools) copied it and its .dop to a new folder and opened it in PL3 with no problem at all. PL3 just stripped anything it didn’t understand from the .dop file

I see the same thing. Many innards of DPL don’t change that much, some interoperability should therfore exist (until the sidecar file format is changed)

It could be the fact that a v3 dop is modified to v4 which give issues reading in v3 double readouts?
Wile a new v4 fresh of the application is clean.

Best way to test is make a v3 dop copy and rename, open this in v4 edit something update. And make a fresh v4 dop by copying adjustments to new file.
Compare those with notepad.

It could be different if DxO versioned the dop files so that different versions of PL could coexist much better than they can now. Now we have to make sure PL doesn’t step all over dop files that we might want to open in a previous version for whatever reason (PL’s habit of changing the rendering of existing edits being a good one), while applications like C1 and Exposure do this for you.

Joanna, I am a bit confused and may be understanding it wrong, but I just tested this:

Camera file: DNG produced by Leica M9
Plaform: MacOS 10.14.6
PL 3, version 3.3.3 build 64
PL4, version 4.0.2 build 45

  1. Load a DNG in PL3
  2. Set 4 stars and make a crop
  3. Export sidecar and close PL3
  4. Open PL4
  5. Select same file, import sidecar
  6. Set 3 stars, modify crop slightly
  7. Export sidecar and close PL4
  8. Open PL3
  9. Select same file, import sidecar

At point 5, PL4 loads the settings successfully.
At point 9, PL3 bails out with message box “No sidecar file loaded”.

Edit: I forgot “Open PL3” before the last step, though that was probably clear.

Do you use the database normally? I use exclusively sidecar files. That could be the reason I am not seeing the problem.

1 Like

Thanks for your reply.
I intend to use exclusively sidecar files, but I could be mistaken regarding to the way to achieve that.
I have in both PL3 and PL4 the “Automatically export sidecars” and “Automatically import sidecars” options checked. Is that sufficient to be using sidecars only ?

That’s what I do

I’m not really clear on what you’re trying to do, but you’ll want to turn those off in both if you’re trying to use two versions of PL on the same image archive. Otherwise PL4 can export sidecars that PL3 can’t read, and PL3 can then overwrite them, effectively discarding your PL4 edits.

The way PL doesn’t do any version-handling of sidecars makes them cumbersome to use with more than one version of PL at a time.

I find it easy to have several versions in parallel. Other than Joanna, I use sidecar files only to transport settings from earlier versions to newer versions. I rely on the databases, which are separate to each version. My way of working means that I have to at least disable automatic export of sidecars and be careful when to export sidecars manually.

Which is what I would call cumbersome. :slight_smile:

Sure, it’s possible, but it’s certainly more error-prone than if the application ensures that it’s not a problem you have to deal with in the first place. Whether or not it’s a big deal probably depends on how you’re using sidecars though.

If you’re only using them to occasionally transfer edits then not a big deal: you just manually export your sidecar when appropriate and are done with it.

If, like me, you want to maintain sidecars for all edits for smaller incremental backups and better fault resilience (one image affected with a corrupt sidecar vs all with a corrupt db), then it’s a bigger problem. Manually exporting sidecars in this case is just onerous. For one, there’s no keyboard shortcut (on Mac at least): I have to navigate the menus. For two, there are typically three popups to dismiss - do I really want to export a sidecar (duh!), do I really want to overwrite the existing sidecars (yes!), and sidecar successfully written (horray!) - and no way to tell PL to stop with the excessive prompting. For three, despite my best efforts, I’ve sometimes forgotten to export a sidecar manually, and then run into the next bit of questionable PL usability: there’s no way to tell if an image has editing that hasn’t been written to a sidecar, and no way to search for these images even if there was. So now I’m really in a pickle: which of my thousands of images is it that don’t have an up-to-date sidecar? :thinking:

On Windows, the PL database apparently contains dop files in plain text, which means there’s a way around the problem: with the right SQL you can simply extract the latest sidecars to get back on track. This doesn’t look to be the case on macOS; at least, I haven’t found any dop files yet. All the settings information looks to be in Apple plists, so reconstructing dop files would require more serious reverse-engineering, that might then need redoing with each new PL version. Not really viable. There is a modification date in one of the tables though (zmodificationdate in zdopitem), so I should be able to use that to identify images with a sidecar that needs updating, if the field is what I hope it is (date and time of last edit).

Needless to say, I’m going to stop trying to export sidecars manually. I’m not happy with automatic export only happening when you leave an image, so that there can be a potentially large amount of work in the db only until you do, but it’s the lesser of two evils.

It’s all a question of being in control or not. Alas, both ways have pros, cons and costs.

1 Like

I am glad to know this as I am having issues with PL4 v4.1.1 build 4479 Elite on a windows 10 64 bit desktop. When I open certain file folders and delete images, when I try and open that file folder again, PL4 tells me there are no images in that folder. I have tried to use Reset in Image Browser but that does not work-- the program will not add a check mark. have reinstalled PL4 but that did not solve anything. And I deleted the affected file folders and the reinstalled them from backup but that did not fix anything either. I just created a support ticket for this problem. I tried loading an earlier version of PL 4 4.0.2 but my computer will not load it because a later version is already installed. I guess OI will have to uninstall 4.1.1 and see what happens.