Bug with Optics Module 1DX + Canon EF200mm f2L IS USM


Photos taken with a 1DX + Canon EF200mm f2L IS USM are identified as 1DX + Canon EF200mm f2.8L II USM.
I didn’t notice any problem up to the last time I used Photolab, in December.

Since last update to version 5.1.4 Build 4728, all my photos using this module can’t be exported anymore: “Unknown processing error”.

When editing in Local Adjustments, I have “Internal error (Cannot get BxU value for XY position.)”


Hello @lariana,

usually this error is when a config Focal length / FNumber is not in rages supported by the DxO Optic Module.
For example, here, photos taken at F2 won’t be supported by the module for Canon EF200mm F2.8L II USM.
If you think the Focal length / FNumber should be OK with the Canon EF200mm F2.8L II USM please provide me some files to analyze on http://upload.dxo.com.

We have to work on htat message to provide something cleaner.


same here with the EOS R and the EF 200mm f/2L IS USM.

only EOS R + Canon EF200mm f2.8L II USM is known.

I’ve send you a picture.

Yes I only shoot at f/2 with that lens. I didn’t have this problem with previous versions of Photolab even if the module was recognised as a EF200mm F2.8L II USM.

Hi, last Photolab update still doesn’t recognize my 1DX + EF200mm f2L IS USM combo.

I just can’t process my photos taken with my EF200mm f2L IS USM anymore since I shoot concerts and I need the Lens Sharpness feature.

Again, in Photolab 5 prior to version 5.1.4, all my photos with this combo were recognized as 1DX + Canon EF200mm f2.8L II USM and I was very happy with the results.
Why taking back this compatibility? With a minimal update even more so???


@Marie, it’s maybe related to this issue.

On Mac, the last version that worked without issues was, all later versions export to DNG without optical corrections (even though applied), but pop the error message with JPEG and TIFF export.