BUG: Nik Install Volume Cannot Be Ejected

I just installed Nik 4.1.1. on an external ssd, from which my Mac runs macOS Big Sur. After the installation, I clicked on “Finish”, waited a while and tried to eject the installer. Instead of doing so, macOS presented this:

I logged out and in and tried again. This time, I got:

I had to restart the Mac to get rid of the installer volume.

Ran the installer again and got the same behaviour.
Other than that, the installer seems to have done its job.

The uninstaller misses some text in german:

I do confirm, as I had the same problem.

This seems to be a persistent bug in Big Sur. You can “Force Eject” the installer after trying to kill the task a couple of times. I’ve had this occur with Nik,DXO PL, and some other software. It has to do with the new security model. It might be that there is a bug in the installer packaging too. I’ve reported this multiple times to Apple, to DXO, and to other vendors whose installers have the same issue.

Issue persists with the update to Nik and macOS Big Sur 11.6.

Moreover, a few app icons have gone after the update (and a Finder restart)

The missing icons might be a macOS Finder update issue. Changing views will replace the generic icons by the ones expected.

1 Like