Bug in photolab 6.1 with decimal value


I’ve just installed the 6.1 version and I’ve noticed that I can’t type a decimal value anymore. When there is a dot in any text field then I can’t type any number.

Is it only me or someone else has the same issue ?

I have the French version, maybe an issue with separator dot vs comma ?


Hi Alexandre - I don’t have the French version, but try this;

  • first select the entire field, and then press Delete … to completely clear the field
  • it should now be highlighted in “red” - to indicate that an entry is required

Can you now type in your required number ?

John M

I can only type Integer, can’t put a dot, I can put a comma, but the field goes red, that’s why I thought about the separator that is different between English and French

Quel est le “symbole décimal” par défaut dans les paramètres Windows ?

comma: ,

Good idea, I’ve tried to change this parameter (region => customize format) from comma to dot, and when I relaunch Photolab, it works. It’s definitly linked to decimal separator


This is a bug and the team is working on fixing it asp


I just tested with v6.1.1 and I still have this problem, the bug is not fixed.

I’ve also tested it, and it’s working now for me.

same here – checked with exposure to key in (+) 0,3 and it showed up with 3.00
(numeric keypad as well with the top row numbers)

That is odd. I just entered +0.3, in the Exposure field, hit enter and got .30 as expected. I also tried several other decimals and they were all correct. I additionally tried the Gamma setting and entered decimals there it and also worked correctly.


rechecked today – the same thing (neither with exposure nor gamma)


You are using PhotoLab in 6.1.1 for Windows, correct? If so, I wonder why you’re still having a problem and I am not. I am still on Windows 10 21H2. Are you using Windows 11?



Mark, I have no idea why it’s different. And I never changed something with the numeric keypad. Also tried with the normal “,” (comma) and top row numbers. :frowning:

@Wolfgang Hello, What is your OS locale and what symbols did you type (comma, dot, numeric or general part of the keyboard)?

Hi Cecile,
the OS is Win 10 Pro 22H2

Screen Shot 12-16-22 at 02.12 PM

= with all latest updates

PL6 allows to key in

  • from the general part of the keyboard
    numbers and dot, but no comma

  • from the numeric part of a ‘big’ standard keyboard
    ( Cherry G81 - 3000 USB / german layout – looks like this )
    numbers only, no comma
    (checked with NumLock ON /OFF)


[ rechecked in my word processor = no problem from the keyboard ]