Broken .dop file (or a preset from the .dop) prevents export by throwing an error

Using DxO Photolab 7.2.0 on Windows 11 here.

Under rare occasions where I am working with larger file (panorama for example) and I have to apply a couple masks (luminosity and brushes), an error “Internal error (Correction failed on execution” will show up.

Once this shows up, my correction is basically doomed and I cannot export this photo anymore.
Here are some observations:

  • If I reset the correction, then the photo can be exported again.
  • If I make a virtual copy of the broken photo, that virtual copy cannot be exported
  • If I make a preset from the broken photo, and apply the preset to its virtual copy which I have reset corrections, it cannot be exported.

It appears to me that something in that particular .dop or preset created from the photo is corrupted. Have you seen this? I have contacted DxO (the second time I see this happening) but I wonder if you have a solution already.

Attached is the problematic preset file.
New preset.preset (467.1 KB)


Is it possible to have access to a RAW file to which we could pertinently apply that preset ? I applied it to an image of mine and there was no problem exporting to a TIFF file.

The DOP file format is rather difficult to analyze because it doesn’t match any known standard format. It’s not XML (which is very unfortunate) and looks like the JSON format but it’s not exactly that (unless something has changed recently). So, I don’t see any way to easily determine, by using an adequate tool (e.g. a syntax checker), whether the preset file has been corrupted.

Maybe testing on one of your RAW files may help.

1 Like

What I can say is that all curly brackets in the file have a matching bracket. Otherwise I don’t see where the problem could be. However, this preset is very big which is unusual.

Thanks for the effort in trying, really appreciate that.

I would like to share the file but it is actually a 2GB tiff file put together by Kolor Autopano Giga, where the source tiffs were 17 photos exported earlier by DxO Photolab.

What can be tried instead is a small version of the same tiff. While the corrections do not seem to apply the same way, it fails with the same error on my side. The test photo is attached. (15% of original photo, before any correction was applied, to keep it small for the file size limit here
[Group 0]-DSC09282_DxO_DSC09298_DxO-17 images_DxO_1.tif (33.9 MB)

May I also ask if you have Filmpack activated on the same PC? I am guessing luminosity mask maybe the culprit, and it may not affect your process if luminosity mask isn’t available.

To reproduce the problem:

  1. Open the photo attached with DxO PL 7.2.0 (with Filmpack for luminosity mask)
  2. Apply the “new preset.preset” file above

In my case, if I try to export the file after applying the preset, then the export progress bar ends up being red and threw an error “Internal error (Correction failed on execution)”.

The huge preset file size probably comes from the fact that I have 2 or 3 luminosity mask spanning the sky, mountain and city, and I used also the brush to remove sections where I don’t want the mask to have effect on.

It looks like all these small changes are recorded as a coordinate of a kind, which seems reasonable.

Yes. FilmPack 7 is installed.

File loaded, preset applied and image exported without any problem. The exported file is available here :

I’m also running DPL 7.2. Maybe it’s a configuration problem : available RAM, GPU (which one ? - is you driver up-to-date ?),… I’m using an NVidia GeForce GTX 1650.

Thanks a lot, it is very good to know it can work.
I am away from my desk at the moment but I should check my other configurations once I have a chance.

I am running it on a system with a Nvidia 3070 and AMD Ryzen 5600, with 32GB RAM. I updated the GPU driver just a week ago so it’s close to being latest I believe. ( for reference, the same problem happened one time to me a couple months ago, when I had an older GPU driver)

I have altered settings in DxO here and there, I might try to restore them to see if that helps.

OK. Let us know if you find what could be the culprit in your configuration or in the DPL settings.

Good luck.

  • Downloaded your small version and your preset, applied the preset and exported the result as 16bit tiff, which took just a few seconds.

  • Opened your original small version in PS, enlarged it to roughly 1,9 GB file size (~ 230 cm long), saved it in the PL7.2 folder, applied your preset and exported the result as 16bit tiff, which then took 2 minutes. The undistorted finished pic is 187 cm long.

So far no problem on my machine (NVidia GTX 1060 6GB).

With such a large file and all the calculations that need to be done at the same time, you may want to increase PL’s cache file size.
To be on the save side i might first undistort the panorama, export a new version and then apply any local adjustments. This should reduce the computational effort.

BTW – out of curiosity i checked your local adjustments and wondered about your 3rd Luma mask (to be inverted ??).

anyway, have fun

Good catch. My DPL cache is set to the max value and installed on an SSD dedicated to the cache and temporary folders created by all applications needing one (DPL, Camera RAW, Photoshop scratch files… and many others).

Thanks again for everyone’s help, it works for me now!
Turns out, the problem is with the stored cache. I checked and I actually also maxed out the cache, and the cache is also located on an SSD which is around 1GB/s transfer and has more than 100 GB of space left, so that shouldn’t have been the bottleneck.

I saw the cache bar (in blue) is nonzero (say 10-20% of the overall length of cache assigned), I tried to clear it and restarted DxO, this actually then allows me to export the said photo normally.

Your tests were what made me believe the problem lies within my system and led to the solution, really appreciate your help Patrick and Wolfgang!

To also answer the question of the third mask:
Mask 1 is applied to the sky and top half of Mt. Fuji, so I can apply a moderately strong ClearViewPlus as a dehaze
Mask 2 is applied to the lower half of Mt. Fuji to apply a weak clearview plus to not overly sharpen the already clear city scape.
Mask 3 is applied only to the top half of Mt. Fuji, as a second dehaze mask. The reason was I found if i applied too much dehaze with Mask 1 (> 70), the cloud can look a bit weirdly darkened. So the Mask 3 is just an enhancement dehaze which I want on the upper body of Mount Fuji but not the sky or city.

1 Like

You’re welcome. Glad that the problem has been fixed.

I have been trying to redo this photo a couple times, as the panorama had artifacts here and there when I used Affinity Photo 2 (broken joints) and Hugin (color shift). Finally I found that Kolor’s Autopano Giga is now free, and using it with cylindrical mode it gave satisfactory result.

After being able to use DxO to apply the correction, I am think I am finally happy with the output, shamelessly taking this chance to share it here: :rofl:

(Mount Fuji taken from Chureito Pagoda in Japan)