Another metadata bug/problem?

I have found what is probably another a metadata bug in Windows PL5. I use Photo Supreme 7 as my DAM and as it’s a new version have been “trying” things out. I added stars to one image, went into PL5 and it asked if it updated the database and I agreed.
No stars were shown (I think others have found this oddity as well) and I closed PL5 and removed the star rating in Photo Supreme 7. Opened PL5 and no image, even tried opening PL5 from Photo Supreme 7 all I had there was a blank image space and no information on the image. The only way I have got the image back was deleting the PL5 data base, no problem for me as I regularly do it. This looks like once you add rating in Photo Supreme 7 you can’t change them in your DAM as PL5 will no longer accept the image at all let alone not use/show the rating.

Hello John,
I tried to replicate your findings but on my side it all works. You do not mention what system you are using but I followed your steps with Photo Supreme 7 and DPL on a Mac/Catalina
No problem at all. Stars were picked up in DPL and also when I removed the stars in PSU it got also picked up by DPL.


I’m using Windows and have repeated it on my setup.

I have worked it out. PL5 has then option to hide star rated image’s and I hadn’t got the stares all selected for display. So if you have image’s star rated you have to ensure you have all the stars selected for display.

1 Like