All images in NIK are no longer recognized

Please see the attached screen capture. This is happening no matter what RAW file I am using from any camera. This file size is only 23 MG. This was sudden. I don’t remember doing anything untoward to warrant this bug.

Does this look familiar? Of course, I would love a solution. Thanks for looking. I’m stuck until this is resolved.

Olympus Camera
Mac-mini M1
macOS Monterey

NIK Collection has never opened RAW files, it only understands processed files, like TIFF and JPEG.

1 Like

I know but it always automatically converts them to TIFF in NIK. I never had to export to TIFF first. I am opening them from DXO using the NIK plug-in button. It always worked before.

OK, sorry but I can’t help you any more as I only ever invoke NIK plugins from within Affinity Photo, not from PL.

The Nik Collection itself does not automatically convert raw files to TIF files. That is done by PhotoLab. I would check the Nik Collection button’s export settings from within PhotoLab. Is this happening with all your .orf files or just some? Are you by any chance trying to open these files directly in the Nik Collection rather than exporting them using the Nik Collection button in PhotoLab? Since the Nik button in PhotoLab converts and exports files to the NIK Collection, that error message referencing an .orf file should not happen. It suggests you file was not sent to Nik via PhotoLab.



DxO has spoken

Yes, the OP already indicated he was aware of that. Even though he indicates he sends images to the Nik Collection via PhotoLab, that error message suggests that the file was either opened directly in the Nik Collection or sent to it from some other software.


I tested it with a jpg and TIFF file and it opened fine. Like I did with these files, I opened only with the NIK export button. I always export RAW file using the NIK button in PhotoLab. It appears the automatic conversion to TIFF is no longer working. Still stuck until resolved. Thanks for the help.


Have you tried reinstalling both packages - I know that is often seen as a last resort (and we shouldn’t have to) but often quickest way to fix gremlins like this.

I reckon Mark could be onto something there … Have you checked your Export Settings ?



Thank you John-M.

I can’t find the Plugin Selector as your screenshot shows.

However, I did use Image > Export > Export to Application and changed Action to Export as TIFF and it works (only for Silver Efex Pro, none of the other NIK applications - I would have to set up all the NIK apps I need to use separately). It’s better than nothing but it adds extra steps in my workflow and defeats the point of auto creating a TIFF upon launching NIK.

Selecting an image and clicking the NIK Plugin Selector still doesn’t work, though. Probably since I’m bypassing it. And clicking now on the blue Export button (say for resizing or cropping) still has Export to Application selected and I can’t change that from the Export window - oversight? :face_with_diagonal_mouth:. I have to go back to Image > Export and click Export to disk. Or do a splat-K shortcut. This really slows me down.

Of course, I shouldn’t have to do any of this if the NIK Plugin Selector button worked as it did since I got PL.

My guess is that you had selected the Nik button option to “Export selected files(s) without processing”. See it circled below in red.

In that event, Photolab will send the current image to the Nik collection without first applying export settings to it. As a result If the image is a jpeg, it will send a jpeg. If it is a raw file, it will send a raw file, and fail as a result. Being able to use that option with a raw file appears to be a bug and should probably be modified.

If you want to send an unedited raw file to the Nik Collection from PhotoLab first apply the “No correction” preset in PhotoLab and then use the “Export to Tiff or Export to Jpeg” Action options in the Nik button settings.



Really ?! … What do you see when you click on the Nik Collection button ?

That is probably because instead of seeing this:

He is seeing this:, which is what you get if you select “Export selected files(s) without processing” as the Action. That is also the reason for his original problem since this Action choice is buggy and allows raw files to be sent to the Nik Collection in error from within PhotoLab.

If you have not already read it, look at my post just above yours.


1 Like

Yes, good catch!

@tpytlarz ( or those who forgot / didn’t know )

This selection,
is meant to → reprocess
a Nik TIFF-file ( avoiding a new TIFF-file export ).

As usual, these selections are “sticky”

and when one returns to
without resetting it in

to export a raw-file to the Nik Collection …

one gets that very notice. :slight_smile: