Affinity Photo plug-ins don't work in 5.0.1

Installed new version 5.0.1 and now none of the plug-ins for Affinity Photo will launch. Configuration is still the same but in Affinity Photo when I go to Menu > Filters > plug-ins > Nik Collection I still see the Nik plug-ins listed but none of them will launch when I click on a plug-in to launch it. Nothing happens at all.

The Nik Collection standalone executable files for 5.0.1 work ok, it’s just the plug-ins for Affinity Photo that fail to do anything now.

So I uninstalled 5.0.1 and reinstalled 5.0.0 and all is fine again.

I had the same problem, but it seems the issue was with upgrade going wrong. Just like you did, I uninstalled 5.0.1 and then installed 5.0.1 again (not 5.0.0) - and plug-ins in Affinity started working!

Thank you for that. I just now tried what you did, uninstalled 5.0.0 and reinstalled 5.0.1 but I still have the same problem. 5.0.1 plug-ins simply won’t start.

So I uninstalled 5.0.1 again and reinstalled 5.0.0 which is at least useable.

Color Efex Pro is the plug-in I use the most by far and that’s the only one I’ve verified the problem with.

I tried again to uninstall/reinstall 5.0.1 and everything works. I don’t know how you specify plugins directory for Affinity, here is how I do it:

  1. As I don’t use PhotoShop anymore, I created a special directory for plugins,


This directory is specified in Affinity Preferences too

  1. When I install Nik, I specify extra directory using ‘+’ and point to this directory.

  2. After Nik installation, this directory is populated, for example ColorEfex goes to

C:\ExtraSoftware\PhotoPlugins\DxO\Color Efex Pro 5

This directory contains two files,

Directory: C:\ExtraSoftware\PhotoPlugins\DxO\Color Efex Pro 5

Mode LastWriteTime Length Name

-a---- 2022-06-22 5:27 PM 2135 Color Efex Pro 5.config
-a---- 2022-06-30 2:28 PM 1331 NikCollection.8bf.lnk

The second file is a link and it points to

C:\Program Files\DxO\Nik Collection\bin\plugins\NikCollection.8bf

I still think that something goes wrong with your installation of 5.0.1, I suggest to look at the contents of directories where you install to verify that files are there.


Thanks for that Alex, tomorrow I’ll try this and see what happens.

Alex I just wanted to let you know that when I installed 5.0.1 the way you did, my problem disappeared!

I can now use the newest version 5.0.1, thanks for your help!