Affinity Photo crashes after making changes with Nik Collection plug-ins

Hi folks - situation as follows. I have been using Google version of Nik Collection quite happily for a few years.
I recently purchased Affinity Photo, and saw that you can use plug-ins with it. I have used instructions to get it to work, both with Google package AND DXO package.
What happens is that I open a photo with Affinity, select a Nik Collection plug-in, make my changes as required, and hit OK to save the changed image.
At this point, the Nik plug-in appears to be working, exits, and crashes Affinity at the same time.
When checking the original image, it remains unchanged.
This appears not to be an uncommon event, BUT - searching various forums, the workaround is to go to the settings button on Nik plug-in, and select ‘After clicking OK’ tab. Then you should be able to choose which layer you wish to apply the changes to…
Problem I have I have is that neither the Google version OR the DXO version show me an ‘After clicking OK’ tab in Settings. :thinking:
Any advice gratefully received.

Just had a quick check using the new DxO Color Efex Pro 4 and cannot find any such ‘After clicking OK’ tab.

Using Windows version btw.

I had the crashes using the free version but don’t have it now with the latest paid version.

The NIK filters apply to the layer you send to eg Color Efex and can’t be reassigned on completion of the filter edit.

1 Like

I find that setting under viveza 2 in the filter list. (google nik)
Though the choice of current/separate layer seems to make no difference.
Do you duplicate the later before running the plugin?

It would appear that it is not in all filters. Can’t find that in Color Efex but it is there in Viveza.

Never noticed that before.

Hi Tom - have tried pretty much all options. I wonder if it’s just the fact that I’m using the free version rather than paid version?
It’s not the end of the world as Nik Collection works fine in stand-alone mode, but it would have been nice to be able to use it as a plug in within AP.

Hello Paul,
I tried to replicate this behavior on a Mac, Mojave, paid Nik collection, everything updated.
It works as expected - no crashes.


I use the old free version and it works. (Mac)
I suggest visiting the Affinity forum.

Hi Paul! Which version of the collection do you use? Windows or Mac?
This information is essential as OSs behave differently.

Best, Tom

… and in other news…
Further to problems with Affinity crashing when trying to use Nik Collection, I have (coincidentally) just upgraded my laptop from Windows 7 to Windows 10, and Nik plug-ins are now working OK with Affinity Photo, albeit in a slightly clunky fashion.
I can make changes with one of the Nik tools, and when I save/exit from Nik, my Affinity image has been edited correctly. :blush:
So ‘Yay!’, but can’t explain, apart from the Windows upgrade?
Thanks to all for your advice and thoughts. :wink::+1:

Have the same issue.

MacOS - Catalina 10.15.7
Affinity Photo 1.9.2
Nik - Silver Efex Pro 2, version 5.0.2