Accessing Images in Apple iCloud Drive

It appears that DxO PL5 has completely lost the ability to see and load images in the iCloud Drive. I searched the forum, and there is a post that says that selecting the images in the File Manager and “Open With” DxO would open the files for editing (in PL4). It doesn’t work in PL5 - nothing happens, no error message. In earlier communication I had with support they said that any data in “Favorites” was accessible, but that does’t work either. Short of copying the files from iCloud Drive to Pictures to process, has anyone found a way to directly access images in iCloud in DxO PL5?


I’ve just opened an image located in my iCloud in two ways:

  1. Dragged an iCloud folder holding images into the sidebar (under favourites), DPL5 showed that folder, showed its content and was kind enough to let me customise it.
  2. Navigated to an image in iCloud and opened it by a right-click with DPL5

Not being able to access iCloud with DPL could be a matter of missing access rights or missing connection.

Try navigating, in DPL’s sidebar to iCloud through UserHomeFolder/Library/Mobile Documents/
“UserHomeFolder” stands for your account name.

None of these suggested actions work for me. In Dxo I can see some of the folders in iCloud - but not the main images folder that I have created. And strangely, I know the trick of navigating ~/Library/Mobile Documents - there is no Mobile Documents in ~/Library. The whole thing is just bizarre. This is on my MBP16 which had a lot of problems synchronizing with iCloud - but the iCloud Drive in File Manger has all the image files, and native Mac apps (like Raw Power and Apollo One) have no trouble opening images. I will have to try my Mac Studio and see if the same thing happens.

You might have to try to reconnect to iCloud and sync the folders.

Check your settings: In iCloud, have you checked the “optimize Mac drive” (or whatever it’s called in your language) ?

I do have optimize turned on for the MBP because it has a 1TB drive and iCloud has 800GB of data. And every other app I have connects just fine. Privacy has all the disk access permissions turned on for DxO so that isn’t an issue.

I think I will reach out to support and see what they say.


I downloaded the Evaluation Version of Pure Raw 2 and installed it. It has no trouble opening files in the iCloud Drive folder - it even lets me naviaged to the files in a Finder-like dialog. I can also right-click on an image or images and select Open with Pure Raw 2, and they open without problem.

Why doesn’t PL5 have the same ability?

It does…but not on your computer. I’d really get in touch with

I did. They gave me a new download link and I reinstalled. They also said I needed to grant PL5 full disk access, which I did. No change in behavior. I sent them diagnostic data.

I learned today that Apple removed the storage kernel extensions in macOS 12.3 (I am running 12.6). Apple has provided a new File Provider extension (which I think Pure Raw 2 is using) - but for some reason it is not being used for PL5 on my two systems. I will see what support says.

I just copied an image from my main drive onto a new folder on iCloud, double-clicked on it and it opened in PL5, no problems.

Yes, you are one of several users who said the have no problems accessing images in iCloud. But it doesn’t work for me (for two different systems, a MBP16 and a MacStudio (both M1). One option would be that there is something in my iCloud configuration causing problems - but other apps (including Pure Raw 2, Fast Raw Viewer, On1, etc. have no trouble at all accessing the iCloud image files. I granted PL5 fulll disk access which didn’t fix it - and really PL5 shouldn’t require full disk access - just read/write access, which was granted. If Pure Raw 2 included Smart Lighting, I would just convert to that, but I use Smart Lighting a lot - unique in that I have never had it make an image worse, which a lot of these auto enhancement features in other software does.

I got the same issue on a M1 MacBook Air, on which I was not logged into my AppleID, but only into iCloud in Safari. Although I saw the raw image file in iCloud, I was unable to open it. Downloading it to the local drive worked though.

I had submitted a support request on this issue and they sent it on to development. Today they came back with a response: “At this time, PL doesn’t support reading iCloud images”. Odd in that many of you have reported that it works on your systems. I purchased the PL6 update, and installed it on both my systems (MBP16 Pro Max and Mac Studio Pro Max), and it also can’t read iCloud on either system.

This is a really disappointing outcome. All the other editing apps I have tried (including those supporting both Windows and Macs) can view and access the iCloud files. And as I have mentioned, the Pure Raw app has no trouble viewing and inputting my iCloud images. This adds a complication to my work - I have to export the images to a local drive, process them, and then export back to iCloud. I would just switch to Pure Raw, but I really like the DxO Smart Lighting.

My guess is that with the release of PL6 they have their hands full and don’t have the resources to deal with this. But that is a mistake, I think.

I think you are misunderstanding the intent of that response. The are various ways people attempt to use PhotoLab iwhich are not officially supported. Sometimes they are successful, sometime they are not successful and sometimes they work intermittently. All DxO’s response means is that although something unsupported may work for you or others, if a problem arises they will not provide support to fix it.


While this response is correct in some ways, it is also debateable in other ways. Let’s have a look at these.

DPL on Mac can not open photo files located in iCloud

  • If we are connected to iCloud in a browser, but not otherwise.
  • If e.g. the photo structure’s root folder is not in the Finder sidebar.
  • Because iCloud is not visible in the SHARED part of the FOLDERS section.

DPL on Mac does open photo files located in iCloud

  • If we’re connected to iCloud Drive through the AppleID system settings
    (and e.g. the photo structure’s root folder is in the Finder sidebar).

Q: Why can it work?
A: When iCloud Drive is connected to the AppleID, the Mac keeps a copy of the photo structure in the Mobile Documents folder of our home Library folder…if there is enough space for it.

As we can see, sidecar files are sync’ed back to iCloud.

If there’s not enough space for the complete structure, items should be sync’ed to that folder as need arises, which means “with some delay”. Note that I’ve not tested this, but that’s what the OS should do.

BEWARE: If you delete an image or set of images, the file(s) will be moved to the trash! That is DPL’s standard behaviour though :man_shrugging:

Yes, I understand that. My copies of PL5 (and now PL6) can’t even see the ~/library folder, so the Mobile Documents folder isn’t available. One of my PL copies does show an “iCloud (Archived)” folder - but it doesn’t contain any of the new folders I have created in iCloud. At one time, PL must have been able to see it - but it is locked into the “old” view of the iCloud Drive. It is all very strange.

My comment was that DxO PL should be able to read and write to iCloud. I have several other apps (including an evaluation copy of Pure Raw) that can view and access the iCloud images.

Apple has released (with 12.3) a Finder Extension that should be used for access. Evidently DxO doesn’t want to use it, for some reason. It is used, I believe, for Pure Raw.

Strange, there must be an issue with your macOS installation or setup.


I also originally thought it was a unique installation issue. But the problem exists for two separate systems - and the Studio install was done from scratch. I didn’t use the Migration assistant. I do know that Apple changed finder support on 12.3 - there is a new finder extension that Apple released then. But DxO PL5/6 isn’t using it.