4.1.1 - huge Windows slow down

Is there any way to roll back to 4.1. 4.1.1. is a disaster and no longer useable. Startup takes several minutes and any imput takes a minimum of tens of seconds. 4.1 was fine.

Is this on windows or Mac? I am on a Mac, latest update and all is working fine with 4.1.1

1 Like

Good morning @BobOwe,

  • Yes, you can uninstall PL4.1.1 and install PL4.1.0 but before, please, create a support ticket here support.dxo.com and provide your logs from 4.1.1 for the investigation.

Log files – %UserProfile%\Documents\DxO PhotoLab 4 logs

Svetlana G.

I’m running windows. 4.1.1. is working fine here. Start up is normal. My inputs, clicks and changes are instantaneous. There is no disaster and its very useable. Providing your log files might shed light on whatever you are experiencing.

4.1 is here if you really want it


Your OS may be the key to the problem. Updating to 20H2 (pc) solved the problem for me. In addition, if this is the 1st time for PL, it will index the files, really slowing down processing until it’s finished.

DXO are being very responsive, as always. Some issues getting log files onto their server but they now have them. Not suggesting that DXO is anything other than awesome, especially Prime for my bird shots with Olympus EMX1 with 300 f4 Pro when in poor light. M34 was never as bad as doubters said but Prime lifts medium/ high ISO shots to the same as native (ISO200) best. Hopefully, the developers can discover where the clash with my other software exists.

1 Like

I am having the same problems with 4.1.1. I have a brand new AMD 3900X system with a RTX 3080, all SSDs and 500mbps internet connection. It takes 1 minute and 40 seconds to load. CPUs, GPU and SSDs are all essentially idle during the long wait period. I have a fully updated version of windows 10 pro. All other applications including RAW processors launch and load content within seconds.

Good morning @BobnWloo and welcome to the forum,

Let me suggest you to address your problem to support.dxo.com and provide your logs with that ticket?

Log files – %UserProfile%\Documents\DxO PhotoLab 4 logs

Thank you,
Svetlana G.

DXO team responding well. Log files with development team. DXO now takes around six minutes to load; therefore start and then go for coffee! Olympus Workspace always slow but no change (although now DXO MUCH slower). Graphics card selected for all photo programs, as previously.
New workflow: down select via Olympus Workspace; only keep very best images; process via DXO but don’t rush it. End result still excellent: m43 ISO6400 like ISO 200! Fabulous program - hope they solve my slow down.

That seems very unusual. Hopefully it’s solved soon!!

A few general suggestions when an application is slow to start or perform operations, as such problems can be difficult to figure out:

Check power management settings. Are hard disks configured in power management to sleep or shut off - or are they always on? (Startups and other tasks requiring storage access can slow down considerably if the hard drive/SSD controllers are in a sleep state and have to wake up.)

I would also look at the Windows Application and System logs using Event Viewer.

Third, I suggest running Task Manager to see if any other applications are hogging system resources such as RAM, CPU, the C: drive…

And as Jim suggested, see if the slowdown can be correlated with a Windows update - one recently installed or one that is not yet installed.

Yes, I have a ticket going and have uploaded logs. They told me to run in an administrative account, which I did with no better result. They said if that does not work then there is a HW conflict. This is a new dell Alienware system.

1 Like

Hi all!

I am testing (for upgrade) DxO PhotoLab 4. I am an older PL 1, 2 and 3 user.

I am experiencing too the huge slowdown (comparing with PL 3, for instance) on Windows 10 (latest version 20H2)

I also noticed the very, very, very slow change of main image when I switch from one thumbnail to another,

I opened the Resource Explorer and noticed that a “Host Service: Cache Service for Windows Font” is slowing down every switch between thumbnails.

I have attached a screeshot.

Maybe this helps the Support Team.



Thanks for the suggestion. I don’t believe my system has onboard graphics.

Good morning @andrewrider and welcome to the forum,

Please, address the issue to support.dxo.com and provide your logs there.

Log files – %UserProfile%\Documents\DxO PhotoLab 4 logs

Thank you
Svetlana G.

1 Like

Hi Svetlana!

I just sent the ticket with all log file compressed (one is very big! about 1 GB), plus the screenshot.

Thank you very much for your help.


1 Like