Update to Photolab 6.5 to 6.6. (Elite version)

Recently I saw someone posted here regarding updating from PL6.5 to 6.6. and he wrote that it could not be launched and he was told possibly out of space or other applications running or memory.
He tried several times, but to no avail, just as he wrote that he had plenty of space.

I’ve been looking for this thread but can’t find it. Luckily I remembered it (see below)

The same thing has happened to me, it says maybe I don’t have enough space (I do, but just to be safe, I deleted a whole library of music so now I have tons of space, but that didn’t help), or there were other applications running (there weren’t), or not enough ram (there is)

When I installed 6.6 I had previously created a restore point (due to the thread above) so I could easily go back to 6.5 which works great.
All other programs also work (exept FP6), all drivers are updated, etc., but therefore no update from PL6.5 to PL 6.6. on my laptop.

Did you try rebooting your computer?


Oh, yes, everytime I tryed. I also shut it down and tryed later - did not work.

@Kib, are you using macOS or Win? You posted on both branches…

Thanks for asking - I use W10 Pro.

okay…your post is in a Mac section. That does not matter, but it would help if you added some info about your environment to the “Name” (not “Username”) field in your forum account preferences. Click on your avatar in the top RH corner and the little figurine icon to access your account preferences.
Screen 2023-05-18 at 23.37.50

Thank You for letting me know. Perhaps it is because I am thinking of changing to Mac - after 25 years with Microsoft :slightly_smiling_face:

But I think now, they are fixing it - at least I hope = After reading this

They answered:
Barbara-SSupport TeamDxO staff



Hello DaveMac,

We are aware of an issue affecting a small number of clients and are investigating to provide a fix very soon.
Please contact our support team or further assistance.

Hi Kib,
I’m back up and running again.
Tech support suggested turning off anti virus, I don’t use one
Turned off Windows firewall instead

Thank You - I will try that, but I did try it, when I downloaded FP6, and it did not help.

It did not work - I also tryed to uninstall FP6 before I did the update to 6.6, if this program was troubled for 6.6, but it does not work.
I will wait if DXO has any solution - have used a lot of time :wink:

Added: The update 6.6.1. solved the problem :smile: