Unable to download fuji module

Hi,
i’m not able to download and install the module for Fuji X-H2s + XF 14 R 2.8 (RAF).
PL7 correctly installed the module for JPG but when try to download the one for RAF it hangs for a while than receives “Te remote server returned an error: (502) Bad Gateway”

The combination is supported since 5.5.0. I have 7.2.0.

Anyone experinced the same? Transient error?

Thanks

… maybe a transient error. This morning it seems to work