Strange behaviour when sending images to Photolab from another program

I uploaded a short screencast to showing the issue. I started PL from command prompt so you can see the exact command used, basically I started Photolab5.exe followed by image file name with full path

The DxOFramework issue is a good clue, David - - Have you reported this to DxO support ?

Meanwhile, it seems like PL is not realising that new images are available - until you “give it a nudge” by switching modes. Is it possible that you don’t have “Live Review” switched ON ?

John M

Hi John

As my latest report with the error messages was a reply to Barbara-S from DxO Staff, Support Team; I consider it to be as good as a direct support request.

I don’t have a “Live Review” option. However, the images are appearing in the “DxO Photolab Image Browser” but not instantly being available in “Customise”.

My “View” menu (identical in Photolab 5 & 6):
DxO Menu

Edit: I discovered that I do have “Live Review” if I am editing a folder. The above is shown if I send image/s from another program for individual editing.

David McA

It shows that DxO staff are monitoring this forum - but it’s not the same as having a Support Ticket that will be followed up; I still recommend raising a ticket.

I’ve just tested again (via Irfan) and I cannot replicate your issue either - so, it’s likely something specific to your environment.

Meanwhile, it wouldn’t hurt to ensure that option is set = ON.


I have registered a support request for this issue (Request #381868), mentioning that it affected some but not all users.

David McA


Hello, good morning,
The bug is identified and will be fixed in a minor update of DxO PhotoLab


Thank you to all involved, both other users and DxO staff.
I feel a lot more confident with upgrading to Photolab 6.

David McA

1 Like

Thx a lot Barbara-S! Any idea about timeframe?

Good to know. But it’s not only in recent versions. I get the same behavior in PL 4 when sending a single raw file from FastRawViewer 7.7. It open Customize with a blank window. Switching to PhotoLibrary and back clears it up. I’m using Win 10 Pro 21H2. Perhaps it’s something that was introduced to all version with a recent Windows update. I can’t say whether it worked in the past, since I’m first trying out FRV and sending to PL 4.

I’ve just tested today’s 6.0.1 Build 33 release. Various issues have been addressed but unfortunately the ‘Open with Photolab’ bug is still there. I’m stil getting a blank screen in Customise forcing me to toggle to PhotoLibrary then back to Customise before I can edit.

David McA

I’m experiencing the same issue selecting images in imatch and sending them to photolab 5 and 6.

Most of the time, I now have to switch from customise and back again before I can see the images.

This used to work 100%

Hi Barbara,

FYI, it might be that the issue appeared (in PL 5.5 and PL4) after one of this MS updates:

3 september 2022-KB5017500 Cumulatieve update voor .NET Framework 3.5, 4.8 en 4.8.1 voor Windows 10 versie 21H2

13 september 2022: KB5017308 (os-builds 19042.2006, 19043.2006 en 19044.2006)

Does this lines up with your bug analysis ?

When will the correction made available for PL5.5 ?

If you are not able to reproduce the issue, I volunteer for a regression on a test build with the patch.

Best regards,

1 Like

I am having exactly the same behaviour. Send image (Edit with external program…) from FastStone to Photolab 5.5.0 (build 4770) on Win10Pro (21H2). Previously (several years using this routine) the single image would open in the Customise window, now there is nothing unless you switch back to the PhotoLibrary tab, then it appears and I can switch To Customize to start editing. It’s not a big deal, but annoying and probably a bug as it has always worked before.

I note the Ctrl+Tab shortcut, that’s useful.

It should be quite easy for the PL team to investigate.

Single image from FastStone Image viewer to OpticsPro 11 works but that goes into the ‘PhotoLibrary’ screen any way! FSIV has never been able to pass more that one image successfully to DxPL and it doesn’t do that with “old” OpticsPro 11 either!

FSIV to PL3, PL4, PL5, PL6.0.1 go into the ‘Customize’ screen which remains blank when it should display the image.

FastRawViewer to PL6 does not work for single image nor for a group of selected images!

XnViewMP doesn’t work at all when you leave the filter set to ‘Tagged’! Neither does it when passing a single image and it doesn’t work when when passing multiple images, i.e. empty ‘Customize’ screen but image(s) present on ‘PhotoLibrary’ screen!

Not on my Win 10 system it doesn’t

I will update to 22H2 later today ( successfully I hope) and see if that makes any difference!

I want to jump in that this regression must be fixed in PL5.5 for several reasons: a) the function was working correctly and ought to work correctly again. b) PL 6 doesn’t fully support my gear as yet (Fujifilm). c) I want to decide when to upgrade, not having to make that decision to workaround bugs.

Hello everybody,
The issue has been fixed and will be delivered soon for both, DxO PhotoLab 5 and 6


@Barbara-S thank you for the fix to both versions and for the update.

Hi Barbara,

Is there already an outlook for the delivery of the fix for DxO Photolab 5 ?



Gentle reminder: when will the fix for “sending images to Photolab” be delivered for PL5? The bug is as per your feedback identified on October 12th and promised to be delivered “soon” on October 27th. We are now early December and it’s annoying to type Ctrl+Tab twice and waiting for every opened image.

Best regards,

Hi Barbara,

I yesterday installed the PL 5.6 update and it nicely solves the “sending images to Photolab” problem. My workflow is now seamless again. Thanks a lot!

Best regards,

1 Like