Sony Alpha 1

I have a Sony Alpha 1 and understand you will begin support in June 2021. I have been a DxO PhotoLab user for several years and currently use v4.2.
Do you need any beta testers for the upgrade?

No idea about beta testing but if you can’t wait I’m working with Sony A1 files without any issue via this workaround which requires Adobe DNG converter.


support of Sony A1 is in progress and is not ready in a beta version.
Don’t worry, it will be available at the very beginning of June.




I have an Alpha 1 and tried to edit the exif data using a free microsoft exif editor. I changed the exif data to ILCE-7RM4 from ILCE-1. File converted to .dng using Lightroom CC export function. When I try to open the dng file in DxO PL 4.2.1, I get a message saying : cannot load image data. I rechecked the exif info and the file is definitely listed with ILCE-7RM4. Did I miss something?

I have moderate PC knowledge but I am not a programmer…

I tried to open your code in the command prompt but I probably don’t have the correct exif editor.

I don’t currently need to convert a lot of files. Just curious to see them really clean. I do have an ILCE 7RM4 but the Alpha 1 is notably superior.

Thanks for your help.


Use the DNG converter not Lightroom. And change the Exif data after. This is the process that works for me.

I suspect Lightroom is debayering and outputting a processed DNG instead of a Raw DNG.

Convert the ARW to DNG with the raw converter FIRST. Then change the Exif data in the DNG.

Thanks MikeR

I got it to work.

Amazing and much clearer than Topaz AI DeNoise.


1 Like

Thanks MikeR for the idea. It worked, but I set the model to ILCE-9M2 in the uncompressed awr files.

1 Like

Yeah I guess it doesn’t matter much. I thought it was wiser to go up to the 61MP body instead of down to the 24MP body.

That and I also have an A9II so if I see A7RIV in the Exif data for an output image I will know it came from the A1.


Does this only work with uncompressed ? I usually shoot lossless compressed. I’ve tried adobe raw to DNG converter and then altering the name in exif tool but it still gives unsupported

Haven’t tried it. Recommend taking a lossy compressed test shot and running them both through the same process to see what happens.

I keep getting Loading error raw2RGBTransform_Prepare failed

I didn’t ever see that error.

I meant I just changed the exif info in the ARW / No dng conversion

1 Like