Rotation does not consider crop in PL5.8

EDIT 2: Actually, there is a problem, see post below.

EDIT: Sorry, everything is fine, I had the correction mode in crop on manual (I don’t remember if that has changed with the update though?)

Old content:
I am pretty sure that this behaviour has been different before, in PL5.8 I am getting black borders when I rotate the image, the crop is not automatically adjusted to fit the image. Could this please be changed back to the previous behaviour?

Actually I notice now that not everything is fine :wink:

When in a first step, I rotate my image, and then in a second step I want to adjust the crop, there is no way that I can control that the crop will be restricted within the valid frame. When I set the crop mode to “Auto”, it will always use the maximal possible crop. But if I want to reduce the crop, it will switch to manual. But in manual mode, there is no constraint, so if I move the crop, there is always the danger that there are some black corners!

I am not sure if this has always been like this, I have a feeling that this behaviour is new in PL5.8? Is there any possibility to restrain the crop to a valid area?

It’s not something I ever paid much attention to but as far as I recall it’s always been like that in PL, i.e.

  • If you use the horizon feature to rotate an image AND the crop feature is set to ‘auto based on keystoning / horizon’ THEN the crop adjusts to the maximum crop possible within the bounds set by the rotation


  • Regardless of whether or not you rotate an image, as soon as you change the crop, the bounds of the crop change to ‘manual’.

I have no memory of PL ever preventing you setting a crop that includes black corners. That’s logical to me, since sometimes you might want black corners, e.g.: