Possible problem in DeepPrime XD support for Pentax K-3iii

I completely agree. After half a life of working in R&D as a product developer of printing systems, I know that no matter how much effort you put in testing your product, it is never enough. Some bugs will be found in practical use only.
So I’ll wait and hope that a solution will be found.

1 Like

Forgot to ask: did you submit a ticket with this bug?
If not, I will do so.

Hi, no, I didn’t. Was hoping for some response from DxO on the forums, but maybe opening a ticket is a good idea, if you want ! Thanks.

I sent a message to Svetlana, hope she’ll respond.

In the meantime I have a different problem: I decided to buy PL6, mainly to re-edit some older K5 files. After the latest release (PL6.1) the preview window doesn’t update anymore, e.g. if you change the WB or NR. Making the application more or less useless. I already deleted the 6.0 installer, so I can’t go back to the older version… Fortunately, it has been recognized as a bug already, I hope it will be solved quickly.

1 Like

Thanks for the info…actually I have just opened a ticket today because I noticed that optical corrections for my Pentax cameras stopped working in terms of preview, while working fine at the export stage. Now you made me check also other sliders such as WB and they are not working ! So it’s a “big” bug that will probably be addressed quickly. Do you have any link where they talk about this bug ?
It’s really strange because auto optical corrections still worked with other cameras so I thought it was something specific to some lens correction profiles and more “subtle” to troubleshoot…
I did not noticed that other sliders (which I rarely use) stopped working as well…

This is the link in which I participated: Bug in PL6.1: WB and Color Rendering don't work on exported DNG(NR and Optical corrections only).
But there are more.

1 Like

For NR the big preview only shows HQ, that is, you have to check NR in the small preview !

To get a quick(er) preview update you can try
grafik
( in Windows )

Otherwise for camera related things I can’t help you
– also not talking about the DNG stuff.

1 Like

Thanks, @Wolfgang , but that is not different from PL6.0 or PL5.
The problem is that many changes in other parameters are not visible anymore in the main window. And that the changes in NR aren’t visible in the small preview either.
Reported in e.g. Bug in PL6.1: WB and Color Rendering don’t work on exported DNG(NR and Optical corrections only) as well.

Thank you. The aforementioned bug apparently plagues only some types of raw files, as files from my Fuji XF10 are handled just fine. Hope that it will be solved for all cameras/file types at once.

Yep. With v6.1 Elite, no updating of previews anymore when I change WB and NR in my Pentax K-3 DNGs. Sorry, but that is a serious bug that turns editing into a blind flight mission.

Please, DxO, take note and fix this. Along with the K-3 III splotchiness reported above, it constitutes a major distractor from an otherwise great piece of software.

2 Likes

Svetlana sent the message about K3 Mk.III and DP-XD to the dedicated team. Hope they’ll find the solution soon.

1 Like

PhotoLab 6 worked perfectly with Raw (DNG) files from my Pentax K-iii when I installed it. However, serious problems have appeared in the last week with DNG and PEF files (probably after the upgrade to 6.1): impossible to change white balance, incorrect color of exports, etc. . I made a support request to DxO today.

1 Like

That is not surprising. There was a serious bug introduced a few days ago in PL 6.1 and PL 5.6 for Windows which makes editing DNG files useless. DxO is aware of the problem and have been working on a fix which should be available for distribution soon.

Mark

1 Like

Thank’s Mark. I am lucky: I did’nt upgrade PL 5 to PL 5.6!

The “preview problem” has been adressed in PL6.1.1.
Now waiting for the next solution, with DP-XD.

2 Likes

@DxO_Support-Team: is there any progress on the issue with DP-XD and the Pentax K3 Mk. III?

1 Like

There was a response to my support ticket. The problem will be investigated.

1 Like

Very interesting, let us know if there is any further progress ! :smile:

1 Like

Hope bit faster than one I have outstanging for well over a year and have little hope of them ever actually doing anything (PL windows not reading distance information for alot of Sony e lenses)

I hope so too.
But do you mean focal length or focussing distance not been read? In case of the latter, I couldn’t care less :slight_smile: