PL7 Elite: Black & White channel mixer not working

I was expecting to see “Channel Mixer” after selecting the “Black & White” option under Colour / B&W Rendering; instead I get the “DxO FP 7 - Channel Mixer” panel below the HSL panel and it has no effect whatsoever… Could anyone offer any help ?

Upon opening

Switched to monochrome

All to the left

All to the right

A radsom setting

None of the sliders have any effect on the BW conversion.

No “Channel Mixer” in the list of pallettes. The only Channel Mixer is the one labelled DXO FP7 - Channel Mixer, and I don’t have FP7. But the channel mixer should not require FP7 as per their help tool tip.

It works for me without Filmpack (under windows 10). I see that you are using a jpg or tiff file, as the white balance is not displaying all the raw modes? Maybe the channel mixer has a bug and is only working with raw files?

Something’s wrong with your installation. The heading of the subpalette should be “Channel Mixer.” Do you have a custom workspace with your own palettes in it? That could cause something like this. I suggest making sure you’re updated to PL7.01, too.

It all seems to work fine for me.

That’s what is puzzling me as well. The heading should have been “Channel Mixer” (without the FP7 prefix). I have reinstalled it, no difference.
Also tried with RAW files, no difference.

As for the version,

Seems to be a bug in the Mac version, both the tool name and absence of functionality.

Attn @StevenL

Related to PhotoLab 7 - Evolution Compared to Versions 6 and 5

1 Like

Ahh thank you @platypus

Just for the sake of reecording all the information… this is with a RAW file (no change of reported behavior)

Tested again with a new Mac user account. still: No Do!

Tried all generic and film emulation variants…to, again, find that CM is dead.

This is quite strange. I’m on Mac and it works fine, but my Channel Mixer is not prefixed with FXP7 (even if I also have that installed). Might be a bug that occurs in the German version installation? Hope they find a fix for you soon.

…this is because you have (most probably) activated FilmPack.

If you are choosing B&W mode, you need to, at least, select B&W film and whatever film you like…

The generic stuff converts the image to B&W and, thus, the channel mixer has no effect, as there are no longer any colours in the image.

The Channel mixer effects are quite subtle and depend very much on the image content.

For a more pronounced effect, e.g. for darkening skies, use the filter palette…

Here, I’ve used a strong red filter to darken the blues and some of the greens.

Colour mode, no filter…

B&W mode, no filter…

B&W mode, red filter…

He is probably using the Mac version. In the past I have noticed that the Mac version adds the extra text to a number of tool names.


I have the same problem, the channel mixer does not work for me.
It makes no difference if I select generic rendering or a black and white film, the channel mixer does not work.
Here is an example with the generic rendering. First the basic settings.

Then all channels of the channel mixer to -100%, this should change the image significantly, but you can see that no change happens.

The same behavior with a black and white film.
The basic settings:

And all channels of the channel mixer set to -100 %, no change in the picture:

I have PhotoLab 7 Elite:

My Mac is a Mac Studio M2 Ultra, 60 GPU Cores, 128 GB RAM, 1 TB SSD, macOS Ventura 13.6.
I can’t help suspecting that it could be a bug in the Mac version, because I couldn’t find any indication in the manual that a black and white movie had to be selected, and also on Youtube I saw a review where the generic rendering and channel mixer were used, but on a Windows machine.

How can I send a bug report to the developers? Or is it enough to describe this here in the forum?

I have exactly the same problem - this on a Mac M1 MacBook Air. I suppose there’s also the possibility the problem is just on the M-series software version. I have a non-M-series iMac too, so I’ll install and check that later today.


I just tested it on my Mac Book Pro 15 " mid 2015 with macOS Monterey 12.7. The channel mixer does not work here either.
It seems to be a bug on macOS that exists on both M-Macs and Intel Macs.

I am testing on a MacBook Pro 16" macOS Ventura.

Here is a screenshot of both PL5 (on the left) and PL7 (on the right)…

Both are showing the same changes for the same adjustments.

Here is an unadjusted screenshot from PL7…

MacBook Pro M1 Max here, also same version PL7 in German. I have also FP7 active (both with trial licenses still). Label is only „Kanalmixer“ and it is working fine for me, regardless of the rendering. Both generic and film. Maybe it depends on the image file type? It is JPEG and ORF (Olympus Raw files) in my case. Could also be the MacOS version, I updated mine to Sonoma.

I get a feeling that the wrongly labelled palette (with DxO PL7) might be the problem.

Take a look at all the available palettes and see if there is one with just 'Channel Mixer" or localised equivalent.

Yeah - interestingly, other than in the screenshots above „Soft-Proofing” is labelled „DxO PL Elite - Soft-Proofing” in my case.

Doesn’t work on a non-M iMac either. Does look like a Mac version thing then. :man_shrugging: