PL5 prevents saving in Photoshop

I have been using PL4 for a year and have recently upgraded to PL5. A new problem has emerged.

I process raw Canon files in PL5 and then save as 16-bit tiff. I then read this tiff into Photoshop CS5 extended v.12.0x32. After further processing, I try to save as a jpeg. I receive the message:

Could not save a copy of [the-new-name-of-the-file.jpg] because the file is already in use or was left open by another application.

I have to close PL5 in order to save in Photoshop. This behaviour does not happen with PL4.

Thanks for any help.


Interesting. I have the same workflow except I’m using Affinity Photo instead of Photoshop for the last stage of image processing and I haven’t had this problem at all with PhotoLab 5 and Canon raw files to 16 bit tiffs to AP to jpgs.

I can confirm this behaviour. After PL5.0.1 has finished exporting a .CRF2 or .CR3 as a TIFF, I open it in Photoshop (via PL’s ‘open output file with’) but then in Photoshop I can’t save, or even save as, the file until I close PL5.0.1. PL3 did not behave like this.

I suppose this might be fixed in PL5.0.2 but I don’t know yet, it’s still downloading as I type.

Thanks, Stuck. I have raised a ticket on the problem. PL4 also doesnt behave like this.

I’ve got PL5.0.2 running now. This behaviour is still present.

I know you’ve already raised a ticket but I’ll tag Svetlana @sgospodarenko in this post as well, to be sure this is seen by DxO staff :smile:

Did you try to ‘break’ it down to 8bit and save it as jpeg?

I also have this issue which I think started from the 5.01 update.
Note: I am opening Photolab-created 16bit TIF files in Photoshop and failing to save them as 8bit JPG, while PhotoLab is open. If I keep the unsaved file open in Photoshop and close PhotoLab, I can then save the file.

David McA

I’m also getting the same message in PL5 (which I bought only a couple of days ago and updated again yesterday to the newest release). I am exporting a photo to PS Elements, then adding a “style” to a frame I’d added in PL5, and trying to save.

I exported the file to Affinity instead and simply saved as a JPEG, without editing. There was no problem doing this, or with then opening this same file in PSE, working on it, and saving it.

I notice that there are lots of .tmp files appearing alongside the photos in the relevant folder, with file names beginning ps. I’ve never see these before when using PSE to work with images exported direct from PL4.

I also normally work with Nik filters in PSE on images I’ve “exported to application” from PL. After doing this and re-sizing I add a watermark in PL, and a white frame. I export that file to PSE to colour the frame grey and add a style. So my images tend to pass back and forth quite a bit from PL to PSE, and this has never caused an issue before.

Exporting to disc from PL5 and then opening the file in PSE causes no problem.

As per David McA, I can save the file if I first close PL5. However, if I export a TIFF from PL5 to PSE and then use Nik filters on it, I can then save the resulting JPEG in PSE without a problem. What I don’t seem able to do is add a frame in PL5 “Effects” palate and export it to PSE and then work further on this image in PSE and save it while PL5 is open.

If I understand you correctly, you are getting the extra .tmp files, as I am; but you have no problem saving the files previously saved in PL5 in other programs, while PL5 is still open.

I raised a ticket, but have heard nothing from the developers. I have gone back to PL4.


You mention that you have gone back to using PL4. It may be entirely irrelevant but I still have PL4 operable on my PC. I don’t remember PL3 remaining on my PC in the same way when I updated to PL4.

Yes. PL4 still works as before. Some programs seem to overwrite earlier versions, but this one has not. I mever had PL3.


It seems that I can save the file in PSE after “export to application” from PL5 if I select a different image in PL5 before saving. In other words, if I ensure that the image I’ve exported, worked on in PSE and want to save in PSE is no longer selected or showing in the customize panel in PL5, I am able to save the edited image in PSE without the need to actually close down PL5.

This displays the classic symptoms of file locking. PL5 is not releasing the lock on the output file and when LR tries to overwrite the file it cannot because of the lock held by PL 5.

If you try to save as a different file does it work?

The only fool-proof way I seem to be able to consistently save the file in PSE is by first de-selecting it in PL5.

That fits in with locking issues - deselecting in PL releases the file lock.

A message from DxO Support indicates that my problem has been identified and will be fixed in an upcoming version, probably 5.1.1 at the beginning of 2022.


Thank you for the update. I can live with this irritation until then.

Thanks for the info. It’s only a minor irritation for me but it will be good to have it fixed fairly soon.

PhotoLab 5.1.1 arrived earlier than suggested --TODAY!

The problem of this thead has been solved.

Many thanks to the development and bug squashing team, and Season’s Greetings!