PL4 with AMD RX580: Save has Failed Internal Error (Correction failed on the execute stage)


now i have install 21.4.1 and it works great. Before that I had to switch to only one develop from Prime Noise Correction. now I can develop 2 images at the same time as usual. Since I have updated my BIOS and it works now, I think that it has something to do with the BIOS …I have a gigabyte x570 elite board with 32 GB and a 3600 AMD and RX580 graphics card. Update AMD AGESA ComboV2 this is F33h.

1 Like

I also have a motherboard with a x570 chip set. I updated my bios to include AMD AGESA as well. however the error still persists here with the 21.4.1 AMD video driver. Back to 21.2.3 for me.

1 Like

now i have the problem with AMD 21.6.1 driver… my workaround ist that i only export one photo a the time…

did you try to fall back to version 21.2.3?

1 Like

I can’t i must use a newer driver then 21.2.3
So i export one File at one time…
I hope DxO will fix it…

Hello @Artphotowerkst,

You should at least try driver 21.2.3 to confirm that the issue is only coming from graphics driver and not something else. Then you can reinstall a newer driver.

If the issue is in the graphics driver, DxO can unfortunately not fix it, and the best thing to do is to complain to AMD support. You can obviously stay with a single export at a time or change your GPU, but these are only workarounds and not a nice experience.

Best regards,

1 Like

AMD 21.2.3 driver works. I hope there is a way that also new driver from AMD will work in future.


Today, 01/11/2021, the only way to have photolab 5 with prime activated and no error in export file, is to use the adrenaline driver 21.2.3, no way with other driver, also the last. Can you work on this proble? My graphic board is a Sapphire radeon rx580 nitro+ with 8gb of vram, not a recent one but a decent one for my work.
Thanks in advance

1 Like

Hello @Fabrizio,

Our answer on this matter has not changed:

Best regards,

@Lucas Thanks very much. Sorry for the mistake. I managed to get it all working by turning off opencl and setting the graphics card to work and not graphics with the latest certificated driver available.
Best regards.

When I try using deep prime with PL5 on my Fuji RAF files I get an error message from the Adrenalin software (driver timeout). The software shows me a GPU usage of 100 %. When checking with the task manager in windows, the GPU actually is only in use for about 2-3 %. The adrenalin software is giving me wrong results. I have to reset the driver in order to show the proper usage of the GPU again. It seems to be that the GPU is not used properly even when the Graphic card is set under deep prime acceleration in PL5.
Developping photos with deep prime produces the same error. However, PL5 and deep prime seem to work, only not together with the GPU acceleration. When switching to “only use CPU” in the settings everything works fine. No error message. However, it’s a pity that the Graphic card acceleration can’t be used.


Could you, please have a look at this thread - PL4 with AMD RX580: Save has Failed Internal Error (Correction failed on the execute stage) - #26 by Lucas seems you have the same problem.

Svetlana G.


That seems to work. No error messages so far. Thanks for the tip.

1 Like

You’re not alone: RX550 (4GB) here (Ryzen5 3600 (6core), 32Gb memory, Win10), usually latest drivers. Same from the ‘beginnings’, Ati (pardon AMD) drivers pretty ‘unstable’.

As previously mentioned:“PL4 with AMD RX580: Save has Failed Internal Error” -->> Change the ‘simultaneously process images’ to ‘1’ is works. Usually works, but it’s still not 100%.

Timeout in the GPU driver side sometimes still occur (even with ‘1’). A few days ago i export approx 240 photo (w/ deepp) and two cases the export failed. Sometimes 1 failed from 30-40, etc.

Sometimes export not failed at all, but AMD error message pop-up (driver timeout) - and a few photo may corrupted (some part of the exported image (i export to tiff) has some blocking, lines, etc. (in limited area, not the whole image, but pretty visible, not just few pixel, like lines height may 1/4 of the image height). For example: from the 240 image export may 1 item get this.

Tipp: as i see AMD GPU ‘timeout’ error message raised (the Radeon Software message) more often if something else also use the GPU: Main example: Youtube video playback in browser (when browser hw acceleration enabled, my case Opera (Chromium engine based)).

I wonder what can be the workaround in the AMD driver side, as others point out, with older driver version its stable. I’m on that, but in very-low priority (as i’m just okay with simult: 1)


Small update: may worth to try the following:
Radeon software → Settings → Graphics → Advanced → GPU workload → Change from ‘Graphics’ -->> ‘Compute’
I get some mixed results with the latest drivers (22.12.1). ‘Simultaneously process images’ with 2 definitely works (at least for me) better. I test at now export 20 photo: Its definitely start the export. Sometimes its export all the 20 without issue, sometimes 3-5 photo not exported (internal error), the remained exported OK.

May i run some additional test (like no other app running, etc)

1 Like

Interesting! I’m still using 21.2.3 as it is the most recent stable version for me. With this driver I’m able to process 2 images simultaneously with OpenCL enabled.

I did set the GPU workload to Compute as well. I also benchmarked if that would influence a basic DX11 benchmark: Unigine Valley. Score stays the same so I’ll stick to ‘compute’ for now.

With the previous 21.11 version of the AMD drivers, I disabled OpenCL but set the ‘Simultaneously process images’ to 2. Processing then worked correctly, but I did get driver timeouts reported by the Radeon software occasionally, especially when applying DeepPrime.

There are a couple of topics about this issue at the moment. Information is quite scattered at the moment, with the topic you mention suggesting to use an old driver version and small workaround in other topic. Is it possible to merge these topics into one? I don’t know if the forum software supports this :slight_smile:



Svetlana G.


I am dealing with this now in January of 22! No fix?
I have sent in a ticket with AMD and I have not bothered to hear because DxO seems to be pointing the finger at AMD, so I am going in that direction. So did everyone here just suck it up and deal with inconsistent vs. very slow software? Or did you folks buy different video cards?

… Yep ! …

Thank you for your response John-M
Incredible. Great job on AMD’s part here. I think I will show my appreciation by not buying another one of their cards moving forward. The brutal thing right now is that I went to buy a video card and there literally were none that made sense for me in stock. When more were coming was anybody guess. So with PhotoLab there is a problem.

I do want to point something out here though. I use Capture One, Neat Image, and Exposure and none of them have any issues with my card. So I am fully awair that DxO is diverting responsibility here. And AMD just decided to do nothing about the issue upon hearing about it.