PL4 Deep Prime slows down after wakeup from standby mode (Windows 10)

When I interrupt my work I set the computer to standby by pressing the power button.

Normally PL4 processes a 20MPix Olympus .ORF file in 20 seconds on my (new) computer.
However after waking up the computer from standby it needs 45-55 seconds to process an image.

I use Win10, the processor is an AMD Ryzen 7 pro 4750G with 32GB RAM.
There is no graphics card, but the APU works fine and three times faster than CPU (20s instead 60s)
I also watched APU activity and frequency in Ryzen Master software and so far I can see the APU is not throttled.

From the task manager I can see that in all cases the APU is used, access to CPU and access to harddrive is minimal, so this is probably not the reason.

Unfortunately this aforementioned slowdown persists until the computer is rebooted.
It does not help to restart PL4 or to unmount and remount the external drive where my images are stored.

Currently I do not understand whether this is a windows problem or a PL4 problem.
Other software and devices behave normal after wakeup from standby mode.

The windows installation is almost brandnew and has all updates applied.

Edit: I found now, the problem is fixed not only by reboot, but also if I set the computer to “Ruhezustand”, a deep sleep mode, where the power button LED is off and does not blink. (My windows is german, so I do not know the precise english word for this and other modes).
If I then wake up the computer, the problem is fixed also.

Edit2: I benchmarked the APU using the program “FURMARK” and this delivers constantly 25FPS at 100% GPU usage. It is not affected by a previous standby mode.
So the problem seems to be with PL4.

I append a screenshot to see before standby / after standby processing time for the same image.

I copied the images to Drive C:, which is a fast SSD. The problem persists and is apparently not caused by the disk performance.

I solved the problem.

The default UMA framebuffer size for the Ryzen 7 Pro 4750G is 512MB.
I increased it in the BIOS setting to 1GB and this reduced the loss of performance by 50%.
Then I set it to 3GB and the problem vanished. I tested multiple times.

Unsolved is the question: Why does this only happen after wakeup from standby mode?
Could be a BIOS problem, a driver problem or an application problem.

Conclusion from this: If anybody plans to get a computer with this CPU and APU, get enough RAM!
This does not mean, I am unhappy; I am quite happy with the price/performance ratio.

1 Like


Let me ask @gpailler to reply to this question.

Thank you

Svetlana G.

Well, it deserves some investigation on our side to determine if this issue is more related to the computer (bios or drivers) or more related to PhotoLab itself (resources management…). I will check with the appropriate team.


1 Like

I would say it’s either a Windows or a driver problem. I suspect some video memory is not freed which means some memory is moved between UMA and non UMA area in memory much more often (and it kills the performance).

Does it happen with others application requiring some level of graphic memory ? Like recent enough game.

I have no games, the most GPU demanding program I have is PL4.
I tried with the FurMark OpenGL Gaming benchmark and it did not happen, but I do not know how much video memory this program needs. (Not much memory, so far I see from Task Manager and AMD Adrenaline Software).
If you could propose another benchmark or other free software I am happy to try.
I also tried Cinebench, but this uses CPU only, so far I could see.

My drivers are installed via AMD Adrenaline utility and should be up to date and my BIOS is the latest regular non beta version.

You can try with 3DMark benchmark for Windows, Android and iOS or UNIGINE Benchmarks

I tried now with FurMark ROG Edition.
This has the possibility to open many OpenGL Windows, until the VRAM is full.
This did not show the effect, while PL4 in the same session showed the effect.

It is probably necessary to use a benchmark or stress test which uses the same API interface as PL4 Deep Prime.
I do not know whether PL4 uses OpenGL, DirectX or something else.

FurMark ROG Edition also has the possibility to use the Vulkan Engine.
And this shows the same effect, it slows down after waking up from standby mode.
I did this test without opening PL4, so PL4 was not involved.
So this seems to be a bug of a driver or API, not of PL4.

PL4 indirectly relies on DirectX for DeepPRIME.

I made now an interesting observation:
I had another program open, which needs at least 2GB dedicated VRAM for OpenGL support. (I used Olympus Workspace, however Photoshop or Lightroom has the same requirement, so far I know)
This reduced the speed of Deep Prime.
It seems, Deep Prime slows down when the dedicated VRAM is used up. It uses then the shared VRAM (if available) but reduces speed more than 50%.

(My GPU is an integrated AMD Vega 8 APU, where the size of dedicated VRAM is adjustable (in BIOS settings). I have currently adjusted 3GB dedicated VRAM.)

This finding could be interesting for those who plan to build or buy a computer or graphics card…

The problem which I described above seems to come from a driver or from Windows itself. After wakeup from standby there seems to be a loss of dedicated VRAM.
I tried several GPU drivers, but this did not cure the problem, the only cure is to have enough VRAM.

Edit: Also I found, MS Edge browser uses up all VRAM, when GPU support is enabled and some videos where watched, and does not release it, when the tabs are closed, only terminating Edge helps. So it might be better to disable GPU support in Edge, because it is not needed with a fast CPU.