PL3 repair tool trouble after more than a couple of repiars

I know that using the perspective and Horizon tools after masking is problematic, but I’m not certain that cropping alone will have an effect on relative mask displacement .


1 Like

Hi Mark, you are entirely correct! Could have sworn I remembered Svetlana posting that any geometric adjustments had that effect. I will delete my previous post so that it won’t mislead anyone. Thanks for the correction. That will teach me not to post before I try it. :rofl:

I believe correcting lens distortion will also impact preexisting mask placement.


Well, the problem appeared in one of latest updates, I never had such problems before. I’m using DxO for a long time.
First of all, lens geometric corrections are done, then lens/details sharpness, then cropping , cloning/repairing is done as the last step, if necessary.

Yep, I learned that one the hard way.

Had similar also the first time, but with local adjustments. Cannot reproduce the steps anymore. But when I came back to the photo, all adjustments were moved to another position. Had to do them all again.

I have been experiencing the same problem. I zoom to 100% then do some spotting. I then go to fill screen and zoom to another area for more work. When I return to the full screen the retouching spots have moved to other locations. I tried this again with the same results.

When this works, it’s brilliant. When it doesn’t, what an unusable tragedy.

1 Like

Sounds like the moving mask problem:

To my knowledge, a fix is on the wish list, but no ETA.

Hi Folks, my first post as a recent new user of PL3. Very interested to read this as just the day before yesterday I experienced the “moving mask” problem (new Mac Mini with Catalina). I was working on an image attempting to repair a sky with phone lines crossing part of it. A former LR attempt worked very well. I found another raw file of the same image shot at the same time. An interesting opportunity to compare LR with PL.

PL has been working very well for me, I installed the latest upgrade (3.3 was it?) a few days prior and unfortunately my intended repairs proved impossible. I just couldn’t understand what was happening and in the end gave up in exasperation. I appreciate there are always bugs and glitches but this is a fundamental tool and needs fixing very soon.

I switched to PL3 on the basis of IQ and the time saved compared to LR, as well as my dislike of the subscription model. However this has to be fixed, and I do want to see a radial filter too. Yes, I understand what a control point does and how it works but I want a full dodge and burn capability and I will switch back if this is not introduced into PL3. I do know there are work arounds etc with control points but I am one of those awkward people - a customer! Ignore me and I go elsewhere! In fact I am holding off buying viewpoint until I am more assured of the route forward.