PL 4 stuck after start while importing database and parameter

After starting PL 4 its hanging now for to long at the same position, as you see in the screenshot. Question now is if I should force quit or wait a bit longer?!

But its lasting now at that point for already 15 minutes.

Did you check the minimum OS version?
macOS 10.14 (Mojave), 10.15 (Catalina) or 11.0 (Big Sur

Ok did not :wink: but did now. Don’t have an i7, but if more than my iMac 2017 Retina 27-inch with 3,5GHz intel Core i5 with 64GB RAM and a Radeon Pro 575 4 GB should be necessary, than there is something going wrong. Lates Mojave btw.-

where did you find that?
I’m still on High Sierra, I guess I’ll wait a bit longer then.

I am a windows guy, but sometimes a instal jams.
I usaly abort or kill by application management.
And just restart the installation.


I just did Peter. Its loading now. Let’s see :wink:

Start here
and than to

I guess I have to check if Mojave run well on an old 2013 imac 3.1 GHz Intel Core i7 :thinking:

It’ll work. How well is hard to tell…

I run plv4 windows version on a i7 4770 3.4Ghz and 1gb geforce 680 or something like that. And 32gb ram.
Ok Deepprime export is 1.16 minute per image… :persevere:.
It takes 18gb of ram in full throttle and no gpu usage.

Not ideal but in edit modes it’s working and with not irritating delay when i start or close local adjustment.

Export, wel, take a break when your done and export is running. :coffee::cookie::smile:

1 Like

Update: After 2nd force quit, its showing now the same startup, but telling me “loading” with a very slow on going progress bar. It looks like, PL 4 was not tested in regards to update an older database version, or whatever. Otherwise it would not take so long. Does it try now to convert all my .dop files???

1 GB is likely short but apart from that GTX 680 isn’t that bad, so you may give it a try if it’s allowed in Preferences > Advanced > DeepPRIME acceleration.

Just checked, it’s worse:
Gt 635…

scroll down to the bottom of the list…:sleepy:

Its DxO Phtolab Mac here, or not?

If you want to help us investigate:

  • Open Activity Monitor application
  • Type “dxo” in search field on top right
  • Select “DxO PhotoLab 4” in the list
  • Click on the gear icon above and choose “Sample Process” and send us the output

There is no conversion of .dop files. However, you might want to try deleting the database. I would back it up first.


Yes, but no mac user was replying so i did ask about your OS.(tried to help you)
And @mikerofoto asked about preformens on a old i7 so i replyed about the counter version namely my old desktop.

Ok it looks like I made the mistake not to use the trial version first. But also never had to. But I never imagined that simply starting the app would be a problem. But now I have been taught a better one. I will request a refund if possible. Very frustrating. I can only recommend everyone to test PL 4 first. Apparently the requirements for hard- and software are quite high.

Thanks Peter, but unfortunately I can’t do anything with your explanations. The only reason is that Windows and the corresponding hardware are like from another planet for me :wink:

1 Like

Same here in the mac world. :grin:
Do you have a big Database in v3.3? In windows it looks for personal settings, database and presets which it “copies”. So i assume in mac OS the same happens.
As @mwsilvers suggest it maybe choking on the large amount of user data of v3.3 which it needs to digest by installation.
Dopfiles are only changed updated to v4 by selecting a folder or if you activate indexing.

Lucas posted above a way to find out what’s your issue.

(I hope some mac users can help you in the mean time.:blush:)