PL 4.3 Sony A1 images scrambled

I’m no longer having any trouble with uncompressed files. Perhaps the one that I had an issue with was passed through another software. Anyway, I’m fine with uncompressed RAW files. Thanks.

The issue that I have is with looseless compressed files. I haven’t tried PL4 with uncompressed files.

I also confirm that the problem only affects lossless compressed files. Uncompressed are fine (although I am certain that they were not two days ago!).

Try using The free Adobe DNG converter to convert your lossless compressed files to DNG to use in DXO. This may work until DXO can implement lossless compression support.

Marie, can you provide any update here? Developers confirmed they see the same issue with lossless compressed files? (This issue is widely reported in Sony forums as well.)

Any timeline on a fix?

Hello @MikeR ,

fix will be released on Wednesday :slight_smile:


1 Like

Still having issues with Sony A1 lossless compressed raw files… any progress?

Hello @photosafari ,

we fix it in PhotoLab 4.3 but if you still have issues can you provide us some RAW test files ?
Could you, please, upload it to under your forum name (instead of the support ticket number) and let me know when ready.

If you have troubles in Pure RAW fix is not released yet, I’m looking for when it will be released.


Just thought I’d add that lossless compressed pictures open normally for me on the new version of PL. Worth noting that any pictures that I had opened in DXO before the update come up with a scrambled preview in the image browser until I make any edit to them (presumably because a new preview is then generated).

1 Like

Thank you. This is in regards to Pure RAW… so please let us know when a fix can be expected.

1 Like

As a temporary workaround you can probably use the free Adobe DNG converter to generate DNGs that can be processed.

1 Like

OK, I’ve tried saving the ARW file to DNG with Adobe Photoshop, and then, bring the file in PureRAW. Guess what! It works!!! :grinning:

It’s slightly additional steps to do, but, al least, I can start processing my images. Hope the fix can be issued out soonest possible ya!

I’ve even factory reset my SONY a1, same problem. I noticed that PureRAW works fine for the files that were shot on v1.0 firmware on the a1. I can still process those old files. Since I’m a bird photographer, I shoot mostly using Lossless Compressed and Compressed RAW.

I really hope that the fix can be issued soonest possible since I just came back from an assignment and have GBs of images to process.

Thank you

Same here. It started to happen last Saturday.

Ditto for A1 and PureRaw


Just want to see if there’s been any updates on the development side of PureRAW for the Sony A1 Lossless Compressed format?

I had submitted a ticket a couple months ago and all they told me was that it’s being worked on.

Any update on the Pure Raw fix for A1 lossless compressed files?



it’s planned for this Autumn.
If i get more precise information I’ll let you know.