PhotoLab 7.0.2 crashes when exporting an image using Deep Prime

Hi All,

Running PhotoLab v7.0.2 on a Microsoft Surface Laptop 5. When I use Deep Prime and then export the image to 100% JPEG, PL crashes every single time. If regular Prime is used, it works fine.

I tried deleting the sidecar file after it first happened in case it was and isolated corruption but it kept happening.

Device information:
Surface model: Surface Laptop 5 Model 1950:1951 i7
Windows 11 Home
OS build: 22621.2428
Processor: 12th Gen Intel(R) Core™ i7-1255U
Installed RAM: 16 GB
Storage size: 348 GB free of 475 GB
Intel(R) Iris(R) Xe Graphics
Screen resolution: 2256 x 1504

It’s a know issue.
Please make sure your GC drivers are up to date.


1 Like

Does it crash with Deep Prime XD too? I have exported lots of images with 7.0.2 and Deep Prime XD with no issues a couple of days ago.

I hadn’t tried Deep Prime XD in a while as it was a bit slow and regular Deep Prime was sufficient for me anyway.

There were some firmware and driver updates available for my Surface Laptop 5 so I installed them and also two Windows 11 updates. As far as I know it’s not possible to separately install graphics card drivers for the Surface devices - the GC is onboard and all drivers come through Microsoft updates.

Anyway, after updating my laptop, both Deep Prime and Deep Prime XD are now working.


Please take a look at

I don’t know if the graphic cards in the surfaces use the same drivers for example for the Nvidia 3050i

take it as a starting point for investigation

but if your system is running now don’t change a running system :grin:

Thanks, yes it has been ok since the firmware update so I will leave it as it is for now!