Optics Module Installed / Not Installed

Just upgraded to PL 5.1.1 and had a new lens. PL hung while loading the optics module for lens Pentax HD D FA 24-70mm ED SDM WR, camera Pentax K-1 II. Now under the Optics Modules drop down it shows the optics module is installed, however on the photos themselves it says I need to download the optics module. When I click on the green camera to download the module nothing happens.

1 Like

Good morning @MikeCross ,

Could you, please, create a support ticket on that via support.dxo.com and provide your logs there ( Log files – %UserProfile%\Documents\DxO PhotoLab 5 logs)

Thank you
Regards,
Svetlana G.

This is the same problem that I discussed a while back with PL4.

In my case, it seemed to be related to a particular Win 10 version. However, since then, a couple of others have also reported it.

At that time, DXO decided to do nothing about it and closed the ticket. I guess they thought that the problem would go away by itself.

Try uninstalling the module and then reinstalling it.

Yes, I tried this and got the same problem of it hanging at the end of the install and having to use Task Manager to end the process. When I got back it, it showed installed but the pictures showed that they were not corrected.

1 Like

How long did you wait before you ended the process? How many images using that module were in that folder? In my experience the process doesn’t appear to end until the module is applied to all the appropriate images. On a couple of occasions I had to wait for several minutes for it to end.

Mark

Good morning,

@MikeCross as a temporary workaround I can suggest you to move the images in a new folder outside PL and then launch PL - > the modules should be applied.

Regards,
Svetlana G.

Svetlana, that worked! Thanks for the work around, and love the product.

Mike Cross

1 Like

I have this problem on PL 7 Elite.

As far as I can see, PL7 seems to think it’s scope is every photo it can find on my computer or network, which is 10s of thousands and makes it intolerably slow.

I don’t understand what you are seeing. What did you select as the default folder in PhotoLibrary? I’m on Windows 10 and my default folder is Pictures which limits access to the image subfolders under Pictures.

Mark

Hi. I have no idea how to specify a “default folder”. I’ve looked in VIEW / SETTINGS to no avail.

When I open Photolab since upgrading to PL7 or when I add an optics module, I have a long wait and eventually get the following display. I think the long delay is because it’s been trying to (re-)index everything it can find on my computer and network and cloud locations. I’d prefer it to index only my S: (network attached storage) drive which is where I keep photos for Photolab processing.

When we select a folder in PhotoLab’s PhotoLibrary sidebar, that exact folder is checked for images, but PhotoLab does not normally dive into folders that are contained in the selected folder…except in the following cases:

  1. Indexing by manually requesting it through the context menu
  2. Something is wrong.

On my Macs, Indexing takes about 30 Minutes for a complete folder tree containing about 25’000 image files. Once hat indexing is completed, all further actions are slightly faster, but rendering the images in a selected folder takes some time, which also depends on the default preset you chose.

As for “something is wrong”, you could check DPL’s preference settings and disable the checkbox that enables DPL to dive into sub-projects and see if this changes how DPL handles (sub)folders, which would be unexpected.

As paying customer, I’d also get in touch with support.dxo.com.

1 Like

There is no automatic reindexing. It is a manual process that you need to initiate. You are already pointing to your pictures folder, I’m on Windows and have around 80,000 images on my more than 7 year old i7 HP computer. It takes around 12 seconds from the time I start PhotoLab 7 until it’s fully loaded and ready for editing. I acknowledge you’re having a problem of some sort, bar barring an analysis of what’s happening with your computer during PhotoLab startup, off hand I can’t supply a solution.

I will suggest though that the issue may be related to the fact that you’re not using a local drive for your images., but rather a network attached drive. Perhaps others who are accessing their images in a similar way can provide you with some assistance.

Mark

1 Like

I have a DXO optics module installed for a particular (frequently used) body and lens combination (both RAW and JEG versions).

It seems that it is recognised for photos up to a certain date, but for photos taken after that date they display with a green dot in the top right hand corner of the small version of the image at the bottom of the screen suggesting I need to download the optics module. If I click on the green dot nothing happens.

I’ve tried attaching my old (PL5) database to PL7 instead of the new one and suddenly my optics module is recognised.

Is recognition of an optics module somehow connected with the indexing process? I really don’t know what happens “under the bonnet” (“under the hood” to USA readers). I just use the accelerator and brake and steering wheel and expect it to work …

By the way, is it abnormal that my PL7 database is over a gigabyte? My PL5 database is 141 megabytes.