Latest photoshop update (M1 ARM) - lost Nik collection & cannot get it back

My Mac M1 updated photoshop to the native ARM version yesterday - the Nik collection has disappeared. Tried a reinstall - its still not showing up. Will it not work with the ARM photoshop version?

I cannot access the Nik plugins with Photoshop 22.3 either, while PS 22.2 works as expected.

According to DPREVIEW, PS 22.3 has a few limitations…

Meanwhile, I’ve tried a few things and can report that I have the Nik plugins back at work.

Here is how I did it on my iMac (Intel, macOS Mojave):

  • Quit out of PS
  • Select the plugin folder located at /Library/Application\ Support/Adobe/Plug-Ins
  • Press command-I
  • Click on the padlock and enter the necessary credentials
  • Propagate the rights to all objects (see screenshot)
  • Close the Info window and start PS

CAVEAT: Can’t say whether this hack impairs upgradeability of the Nik…
UPDATE: Does not work on MacBook Air M1. Workaround: Open with Rosetta.

1 Like

I too lost my Nik Collection V3 due to the 22.3 native M1 update for Photoshop. I’ve tried everything to get them back with no luck.

The only way to get the plugins to work as designed is to open PS with Rosetta, but that defeats the object of it being a universal app.

Not keen on moving folders around as I will likely forget what’s supposed to be where.

I would imagine it’s an easy fix, so hopefully we’ll get an update soon

I guess that until DXO produce an M1 native version of the Nik plugins we are stuck with the versions of PS & LR that run under emulation …

Hi, maybe your correct I am not sure, we can only keep our fingers crossed that DxO get their teams looking at the issue asap.


Even moving the folders around doesn’t fix the problem. I’ve tried that.