I'm ready to scream! Repair tool targets moving when zoomed

OK. PL7 latest release.

So, I’ve just spent an hour de-spotting a 6cm x 4.5cm scanned negative. I was zoomed in, worked the whole neg in strips, then zoomed out. Only to find that all the targets masks had moved by a few mm, so all the already treated spots and hairs were once again visible!!!

@Cecile-C, @Fabrice-B, @Barbara-S, @Tiziano-R, anybody from DxO - please reply this time.

This is getting serious. Not only have I purchased every version from PL1, even if I got a freebie for participating, spent innumerable days testing betas - now I end up wasting time on a customer’s image that he is waiting for.

1 Like

Hello @Joanna ,

Could you please open a [support ticket] with all necessary information and we’ll get back to you asap


:thinking: A (justifiable) rant on the open forum like that from such a loyal user makes me really worried about the future of PL…


Bugs happen. Hopefully the cause of this one will be identified and fixed soon.


we need a screenshot that bug in Please post photos of bugs processed with PhotoLab. Thank you :)

Ah for the good ol’ days when @sgospodarenko would would send @Joanna 's request to one of the engineers working on PL7"


I know and understand and accept that. My point is that the manner in which this bug has been presented is very untypical of Joanna’s usual calm and measured tone. That she took to the forum in such style suggests to me that no one at DxO was listening to her and if they’ve stopped listening to her…


Indeed there was a number of times she checked things after support said no problem and agreed there was and took them up and got them sorted
I alway think this acting for users is why she was removed from the fourm .


I don’t know whether what follows is related to this issue but anyway…

The size of the Retouch tool brush is specified in pixels but one may wonder what this actually means : the brush size never adapts when zooming in or out. Apparently, this size in pixels is an absolute value related to the display, not to the pixel size in the preview.

Once the size has been specified, it stays the same whatever the zooming level until the user specifies a new size. IMHO it should be adapted : a pixel is a pixel and its size in the image depends on the zooming level. So the brush should grow or shrink according to the latter. Also, when a Retouch anchor point is activated, the brush size is not restored to the size it had when the mask was created.

Since Joanna first zoomed in and then zoomed out when the work was finished, it is also possible that for given masks, she also had to zoom in or out a little, to add a few strokes or to erase some areas from the mask. What is exactly happening when doing this without changing the initial brush size ? How does this affect the mask construction ? How does this affect the mask or source position when using the Transform tool ?

Just guessing around…


Yes, she was a good mediator.

I have privately written to Barbara, apologising for the “rant”, but when you’ve got a customer waiting for a print and you’ve just spent an hour, only to find that the work you’ve done has been lost, it sort of gets to you. Then there’s the recent total lack of response from Dx0, which even applies to the beta forums before they closed them down, which makes me wonder who has said what and to whom in DxO to alienate them from communicating with us.

Further news, I have just reverted to PL6 and this problem is exactly the same there.

Look carefully and you will see target masks, with faint dots that those masks were covering, usually, but not always, just down and to the right.

And here is the entire image, just to show how many repairs I have done so far, at the second attempt - and that is just going around the edges.

@Barbara-S I don’t have time to make out a report on this at the moment. After another hour in PL6, I am now even further behind and will have to use Affinity Photo to go through this all over again.


This is how things work in Lightroom.

1 Like

Yes, but this is a different situation. In this particular case it’s very understandable why she’s so upset. She’s doing work for a client. If she had found this bug in the normal course of things, she likely would have presented it in the same fashion as other things she’s identified in the past.


Indeed, the first time, all I did was rotate the image in PL7 before starting to re-spot but, when that failed, I then rotated it in in PL6 and immediately exported a copy so that all I had was a “virgin” image

But, see my screenshot in the previous post - the offset is clearly visible.

1 Like


Is this the only image you’ve worked with that is having this problem? Could it have anything to do with the small physical size of the scanned negative or the resolution?

I wonder if this problem is Mac specific. Since I’m on Windows , if there’s anything I could do to help you out, let me know. At this point I only have PL7 installed.


I may remind you of this old post, where it was already mentioned that local adjustments are not compatible with global image transformations.

When some of the users, including me, complained that this is a big misconception, many of you who are complaining now in this post, were defending this behavior, as one could ‘just work around it’, by doing any global transformations before doing any local adjustments.

If this behavior now also happens by simply zooming, then this is of course worse, however, I think the problem should be solved from its root once and for all. Me myself I was in the same position back then and pretty annoyed that I had to redo all my local adjustments, only because I wanted to do a simple adjustment of the horizon afterwards.

The post of mine which you linked to was in regard to the order in which geometry changes and repair masks need to be applied. I believe @Joanna is well aware of that issue and the current problem she’s having is somewhat different.


Thanks. I’ve done very little repair work in PL7 but, if and when I did, it was just a few small things on a digital camera RAW file.

This is very different. It is a scanned MF (645) neg at 2400ppi, giving a TIFF image of 5406px x 4084 at 240ppi.

I can send you the file by DM if you would like to have a play on Windows. It is the original scanned image, complete with slight tilt.

In the end, to get it done, I squared it up, cropped it and used Affinity on the resized and squared file.

I am not sure about France, but in some less enlightened countries some companies have “customer advocate” roles on their roster …

1 Like

If you would like to send me it, I’ll be more than happy to see if I can recreate the problem in the Windows version. Perhaps you could message me with some specific instructions regarding what you wanted to accomplish, what you did, and the specific order in which you did them. Assuming that I have the same problem you had, I will also play with it to see if there is some sort of workaround.