How do I enter an aspect ratio for the crop tool?

The manual says

When the crop tool is active, a command bar is displayed below the Viewer pane. From there, you can select a predefined aspect ratio, type in your own values, show or hide the grid overlay, reset and close the tool

I am trying to select an area to print on A3 (13/19 or 19/13), and, even with the correction set to ‘manual’ and the crop tool active, I cannot enter my own aspect ratio in either the ‘command bar’ that appears when the crop tool is active - or in the ‘Aspect ratio’ drop-down in the Customize bar control.
Any ideas?

Hi, Bob. This question came up recently, here:

EDIT: According to the current user guide:

  • It is also possible to choose a different ratio in the Aspect ratio drop-down menu, such as 1:1 (a square format), 5:4 (replicating the traditional 5×4 or 10×8 format), or any other in the list. You can also type a ratio (2 figures separated by a colon) directly in the menu bar.

I’m not able to get this working, either in the crop field under the image viewer or in the Crop palette, more than once - if at all. Sometimes a weird ratio works, like 33:10 - but not 19:13. Sometimes a number like 1.5 or 1.50 works - and then on the next attempt it doesn’t. Anything that doesn’t work becomes 1/1. (Windows, with the crop tool active, in the aspect ratio field below the image viewer.)

Maybe I’m missing something, but the inconsistent behavior suggests a bug to me.

May I suggest that you change the category for this topic from “Which feature do you need?” (which is for votable feature requests) to simply “DxO PhotoLab” ? You can also tag the topic with your OS - Windows or Mac - and with “bug” if you’re getting the same behavior I am. I hope this helps.

That’s what I was trying. Doesn’t work for me. 1.65 works - gives me 33/20. 1.5 doesn’t - gives me 1/1. 19:13 also gives me 1/1. Delete gives me “preserve aspect ratio.”

:grimacing: I ran sfc /scannow and found errors. Fixed 'em. Also reinstalled PL4.0.2. At first, it still wasn’t working. Then, suddenly, that changed. Now, as long as I don’t have the pulldown menu visible (I select the field and close the pulldown list), I can enter values and they work.

Video follows. I’m sorry you can’t see whether or not I’ve expanded the pulldown list. When the value remains in the field after I type it, this is because the pulldown list was closed. But the value didn’t always take effect - as you can see. Now it seems to be working consistently - only if the pulldown list of ratios isn’t showing. When that list is showing, manual entry still fails (by design, I’m sure - unless there’s a matching entry on the list??).

The behavior I observe for the crop tool (Win 10 - V 4.02):

  • If the drop-down list is unfolded, you cannot enter a personalized value: if you enter a numerical value, this positions the choice on the first value of the list which begins with this number. Example: I type 1, the ratio 1/1 is selected. Which seems logical.
  • If the drop-down list is not unfolded, I can enter the value of my choice. For example if I want a report in accordance with the formats of the A series (A1 - A2 - A3 - A4 …) I can enter either 297/210 or 1.414. The display will show either 99/70 or 1.414, but the pixel crop values ​​are the same.
  • The orientation of the crop in vertical or horizontal (portrait or landscape) depends on the current orientation before entering the value. For example, if the current orientation is vertical and I type 3/2, the vertical orientation will be kept and this will give a 2/3 display.
  • If you want to change the orientation, you have to change it before entering a value, by taking a corner with the mouse and dragging.
  • But I noticed what looks like a bug: when the previous ratio is horizontal (eg 3/2), then go to 1/1, then back to 3 / 2, the orientation is in the vertical direction (2/3), which is not logical.

In DPL4 (and DPL3) on macOS Mojave, I can enter any ratio, no matter if the pulldown is open or closed. The ratio I enter persists and the crop shows as entered: width:hight.

For A3 (landscape), I enter 420:297, the exact measures in mm. To take into account a border of 10mm (12mm at the bottom), I can then simply enter 400:275…

That technique worked for me as well - the first time. Subsequent tries (to enter 13/19) kept resolving to 1/1.


Here is the visualization of manual entering:

Please, do not forget to press Enter after you manually type the value.

Svetlana G.


Svetlana’s approach works for me on Windows 10 & PhotoLab 4. Occasionally there are glitches when trying to enter a custom ratio, especially if one of the values also appears in a pre-defined ratio, but I can always get there eventually.

  • Gregor, it works for me all the time if the drop-down is closed (but you should pay attention - if the list is in opened state - yes, there are problems with applying the correct value).

Could you, please, double check if the list is always closed when you enter a new value?

Thank you
Svetlana G.

I can verify that this works - so long as the Aspect Ratio box is selected but not expanded. I’d suggest that this is highly unintuitive. Now that I’ve gone through this, I can enter aspect ratios, but, at a minimum, the manual needs to explicitly note the Aspect Ratio needs to be selected - and then un-expanded with a second click. Short term, I’d just link to your video.

At Lotus, we had a usability lab. Volunteer users would come in to try out new products. There were video cameras and a (very soundproof) one way mirror wall so developers/designers could see what the test users were doing with their new baby. A non-intuitive feature like this would have the developers pounding on their side of the glass, shouting No! No! Click over there!
This comes to mind whenever I run into something like this.
Disclaimer: I was a software architect, not a UI designer - and I retired out of software a couple of decades ago

  • It’s only because I did the test of different values, it does not affect the behavior I showed.
  • Yes, exactly - the aspect ratio box should not be expanded when you enter the value manually. We’ll discuss it in the team if it can be improved fast.

Svetlana G.

1 Like

Gregor, I’m discussing the behavior with the dev team right now and haven’t done anything to make you stupid. Sorry, you are not the only one in the Forum, please be patient a little bit.

P.S. If you want your problem to be investigated asap and personally, please create a ticket on

Svetlana G.

in Windows I noticed also this

  • Original photo without any correction which is in landscape 4/3 format

  • want to crop in let me say portrait 3/5

  • choose the crop function and crop tool

  • put in the value ( Aspect Ratio box is selected but not expanded) and hit enter

  • DPL4 gives it a landscape 5/3 ratio

  • I have to choose one of the edge sliders to bring it to my portrait ratio

Maybe it’s of my two left hands with the 10 thumbs :rofl:, but I can repeat it.

This entry is only to complete this thread and needs no direct response


1 Like

So as we can see the manual entering is possible, the things we should solve are the better way to type it no matter the list is expanded or not and some misbehaving concerning the image orientation. We will investigate it.

Svetlana G.

1 Like

What works for me:

  1. click crop tool at top of window
  2. click Aspect Ratio drop down (drop up?) It will expand, showing selectable ratios
  3. click Aspect Ratio drop down again. It will collapse, arbitrary ratios can be entered from the keyboard
  4. arrange crop as desired
  5. press enter to apply the crop

Once you’ve verified this works, you are more than welcome to hand this off to your doc writer(s) so they can save the next user some puzzlement

I have experienced the same problem running both PL3 and PL4 on a windows 10 computer. I cannot enter a desired aspect ratio once I have clicked on “unconstraianed”. When I try it I get a ratio that was not what I wanted. The problem exists with both vertical and horizontal images. I tried different formats like 5:7 or 5/7. Same thing happens. There must be a bug somewhere at least in the windows version of PL.

1 Like

Thanks! That solved it for me. I was trying unsuccessfully to do it using Crop in the side panel.

Is it possible to save a ratio? I often use A4 or 1.414 (it’s a common, important page format) but I always have to put it back there when I need it.

Also, if you don’t mind me saying, I find it frustrating that the Escape key functions as an Enter key when you’re cropping! If a crop goes pear-shaped and you want to maybe skip cropping for later something then the common-sense thing to do is hit Escape but that enters the crop. It even enters the crop if you deselect the crop tool! And if that’s not irritating enough, you then have to reverse out through all the minor changes you made while trying to get your crop right. (Perhaps this is the sort of thing @bobkoure 's usability lab might pick up for you)