Help! DxO very slow on new PC, don't understand

Hello @Frankster69,

It’s really strange as your new machine is powerful enough.
@alex, could you, please, assist here?

Svetlana G.

I have had this experience, i think it was end last year or beginning this year, at my notebook with fresh Win10 installation (maybe Steve remembers). The contemporaneous installed Desktop with same Win10 version and also actually patched doesnt have had this problem. A lot of mail and hijack reports between support team and me follows. Didn’t find a solution.
With every MS Patchday I tried again, and then sometimes the problem was gone. I think it was after the march patch.
During the whole time other programs at the notebook like Affinity, Raw therapee and other programs where fast as before.
No idea what cause the problem.
@Frankster69 I know that didn’t help you, but maybe it’s a good idea to check if BIOS Version, drivers and patches are up to date.
good luck

Or it’s the setting for the database and/or Cache folder in the preferences.
If they are at the standard path anywhere at C:\ drive, they have to build again.
And maybe it’s a thing like Fotothek "Time consuming"

But only presumption…after a lot of years using DXO I haven’t understood the internal way of working :rofl:

Since your computer’s a new build, I suggest:

  • make sure your hardware drivers are all up-to-date;
  • try a different USB port and cable for your media drive;
  • run some benchmark tests: search the Internet for ‘hard drive speed test’ for some ideas;
  • for testing memory, I used to use the software at;
  • try Intel’s diagnostic utilities to see if your CPU is performing properly;
  • check power management settings in Windows: try high performance mode if you aren’t already using it to see if that makes a difference.

You are using UEFI for startup, right? Everything OK with that? BIOS settings look OK? CPU temperatures look OK? (A hot CPU could cause a severe throttle down in performance.)

Have you tried launching Task Manager while the slowdown is in effect? I had a similar problem and discovered an unnecessary program was hogging all the resources.

Hell @Frankster69,

if the problem still exist you can try the steps from

Open Start, type: CMD - Right click CMD and run as administrator

Type in at the prompt: (Hit enter after each command)

Dism /Online /Cleanup-Image /CheckHealth

Dism /Online /Cleanup-Image /ScanHealth

Dism /Online /Cleanup-Image /RestoreHealth

Also run the System File Checker utility:

Open Start, type: CMD - Right click CMD and run as administrator

type: sfc/scannow

This will check for any integrity violations

Restart your system


Hi - could it be related to the problem described here by Robin Whalley:

The problem he has been having seems to be related to DXO PL creating lots of new .dop files, for every image, following an update. It has happened with his Mac and Windows machines. Read his post for a possible solution to explore. Though others have not been able to duplicate the problem.


I had this same problem with On1 Raw 2020. Someone there suggested this as a possible solution;
In Windows 10 settings go to Graphics settings and browse for DXO Photolab, hit the options button and choose High Performance.
It worked like a charm with On1 so I did the same for all my digital art and photo software and I’ve had no problems since

1 Like

Dear @ElaineH,
sounds very interesting, but could you please explain the settings you have done in a more detailled way.
I haven’t heard before about settings for single software.


Windows Settings>System>Display
Scroll down to the bottom of the Display page where you see Graphics Settings. Click on it to see Graphics performance preference. You will see a box to browse from and Choose an app to set preference. Browse and choose DXO PhotoLab 3.exe. Then you will have an Options button where you can choose either System Default, Power Saving, or High Performance.
I have no understanding of why this helps but it just seemed to do the trick for me. I hope it does the same for you @Guenterm


Dear Elaine,
many thanks for the description. Haven’t had taken a look before to these settings for single applications.

best regards

I tried Elaine’s recommendation and selected High Performance. It reduced the launch time for PL from about 30 seconds to 12 seconds! Wow! The GPU makes the difference!

Dear @jamhen2, dear @ElaineH

do you own a notebook or a desktop?. My desktop is configured for High Performance overall, and so it seems, that a setting for single application is not necessary.

But I will make some test maybe in the next days


I’m running a W10 desktop. I can select specific programs for a high performance setting:

Hi Jim,
yes …that’s what Elaine describes, but…if the whole desktop is on “Höchstleistung” or in english “Top Performance” in my mind it does not make sense to bring single applications to top performance. More than 100 percent are not possible.
I think for a notebook with energy settings for optimal battery life, but want to have top performance for single application like DXO this is meaningful.
But that are only my thought’s


…one is for general power/battery life balance, the other is for graphics. Looks like Windows offers a way to manage cpu and gpu performance separately…

1 Like

Thank you Elaine. This really solved the issue!
I hope DxO will point this out in the manual.


1 Like

Hello Klaus,

What was your issue?


Hello Alex,

My annoying issue was very slow response to rendering images and showing images of a large folder. One change in the image settings (such as zooming or changing the values of local adjustments) could take tens of seconds - half a minute… Now it runs much faster.

WIN 10 64 Home, vers 1903.
Inte Core i7-4770 @ 3.40 GHz, 32 G

PL 3.3 ELITE, NIK and WP.

Nikon D850 NF files


1 Like

Similar issues here. I find turning Dxo Denoising Technologies tab OFF during the edit helps a lot. Just remember to flick it back on before you export.