DXO Photolab 6.0.1 error code Internal Error (Error in Init)

Thanks Jayne. No problem with downloading. I’ll take a look at them.

Jayne, I’m having no problem loading either photo into PL 6.3.1 Win 10 Pro. I’m guessing that this is a database problem on your end. Try this test:
1.) Place a copy of “1116.cr2”(all by itself with no .dop nor any .xmp files) into a new folder that PL6 has never seen before named something like “Jayne’s Test Folder”. Rename file “1116.cr2” to “Test.cr2”. Do all this with PL closed.
2.) Open PL and point it to your new folder and see if it will load properly. If it does please let me know and we’ll talk about what to do next.

Hi Jayne,
downloaded both pics and the show up without problem in PL6.3.1 (the latest version for Windows).

Looking at “her” posting history, I believe this could be a spam bot and I have reported it as such.

@Joanna, I just read all three of her posts. What about them give you the impression she is a spam bot? They sounded like legitimate posts to me.


1 Like

I found five…

Most of which seem irrelevant to the topic and four of which are over a year after the topic was last touched.

Ahh, now I get it. We are talking about two different people. The five posts are related to @RachelGomez123. She posted in this thread last October. I thought you were referring to @jebierman with whom @rrblint has been recently conversing.


Hi @Joanna @mwsilvers @Wolfgang Yes I agree that @RachelGomez123 is a spambot but I’m pretty sure that @jebierman is a legitimate poster unless spambots have gotten much more sophisticated and have cameras. Her photos are copyrighted in her name in the EXIF.

1 Like

Hi all, nope, I’m not a spambot, :stuck_out_tongue_closed_eyes:, no clue how - nor desire to be - one. That said, thanks for the test suggestion, Mark. I’ll test it in a little while here, once my coffee has circulated into my brain.


Mark, I had high hopes, database issue sounded logical, but sorry to report, after following your instructions, I still cannot open the file for editing. As before, the picture shows on the ‘PhotoLibrary’ tab, and in the little side picture and film strip on the 'Customize" tab. Tested a few tools, too, just for grins: no reaction to crop, ‘rendering error’ for presets, and “internal error (cannot prepare transform object)” for adjustments and Nik. This is weird. (PS: please note the lens was my EF 100-400, not the earlier EF70-300 I reported.)

Can you post a screenshot of exactly what you are seeing in both Photo Library and in Customize please?

Here you go, Mark. https://www.dropbox.com/scl/fo/13r0sfk9kqtfgychkyerp/h?dl=0&rlkey=7v5fl2064b22wxlbojxhpn2tf

One screenshot of the Library page, one Customize ‘normal’ and one Customize with the bandaid tool selected, as it returns a different error.

Thanks Jayne, let me take a look at them.

Jayne the only conclusion that I can come to is that there may be something wrong with your installation of PL 6.3.1. One more thing that you can try is uninstalling PL then download a fresh copy from your shop account and (re)install the fresh copy that you just downloaded. Be sure to restart your computer between the uninstall and reinstall steps. This has worked for me when I experienced oddities in a previous version of PL. Unless someone else comes along with a fix, then your only other recourse is to submit a support ticket to support.dxo.com but I am pretty sure that they will not be able to repeat the error.

Thanks, Mark, I woke this morning thinking the same thing, the uninstall/reinstall route. Will do, wish me luck! Thank you, and the others for checking this out.

Good luck, I hope it works for you. Be sure to remember to download a fresh copy. The old copy might be corrupted and would just do the same thing. Please let us know how you get on.

Just to follow-up on this. I uninstalled all, reinstalled newest clean PL6 version from website. Still could not open the picture files. However, I’ve found a workaround that’s good enough for now. I ‘open with’ plain old Windows “Photo” viewer, then can save a copy as a .tiff or .jpg file. Once that’s done I can easily open either file within the PL6 Customize tab. Weird, but functional. Thanks again for your help!

Dear Jayne,
Have you tried to open another raw file, e.g. from a Nikon or an Oly, just to see if the error also occurs with this?

best regards


You’re welcome, although I don’t feel like I was very much help. Now that you mention your workaround, you could download the free Adobe DNG converter and convert to DNG. Since your camera and lens are supported by PL 6 then it “should” open the DNG file and would still give you access to DeepPRIME, DeepPRIME XD and DxO’s lens corrections.

Here is the link to the free converter. You will have to open an account with Adobe, but don’t worry, it’s still free.

Hi Guenter, No, haven’t tried any other raw file, as I generally only use my Canon camera. I’ve a Panisonic Lumex I rarely use, but maybe I’ll test with it one of these days, and report if any issue there. This was such a random issue with the Canon, only the four pictures out of the 1444 I shot in January, none ever prior. Just going to keep an eye out for any future repeat, or increase, and deal with it then. Thanks!