Cannot print: Failed to prepare Exif for saving

Hi,
I’m having a problem with printing from DxO PhotoLab 6. I’m using this profile for the printer: Download Center

The printing dialog shows no progress. Instead, I get this error:
One image could not be processed for the following reason: “Failed to prepare Exif for saving”. Printing was cancelled.

This happens regardless of the chosen paper size and output device - I can try and print to a Canon PRO-1000 or to PDF, and the result is the same.

This does not happen with a different color profile from Fomei, however. Any ideas how to even start troubleshooting this?

Hi Robert – and welcome to the user forum.

Your Link leads to Hahnemühle’s start page, but not to the paper profile in question.

So, which paper profile you have problems with?
And what is your OS – Mac or Windows?

Can you share the relevant pic (via dropbox or else)? Is this the only pic that does not work / print?
( To my knowledge, a paper profile has nothing to do with "“Exif for saving”. )

The profile I’m using is Hahnemuhle Photo Rag Baryta for Canon PRO-1000. It occurs for many different photos from different filesystem locations, shot with different lenses. Running on Windows 10. As far as I can tell, the EXIF fields from the camera and lens look sane.

Since writing the previous post yesterday, I’ve discovered the likely culprit:
When I point to the .icc file stored in a directory on my Desktop, it fails with this error. If I point it to the same-contents .icc file, but this time in the system directory (C:\windows\system32\spool\drivers\color), it works flawlessly.

As far as I understand, the print process must be failing when embedding the ICC profile into the file that is to be sent to the printer. Can’t guess much more from the error message given. I wish it was more detailed, really.

Right now my workaround is: copy all ICC profiles into the system dir, point PhotoLab to that.

For reference, the directory from which the ICC profile refused to work during print is: “C:\Users\Robert\Desktop\Profile kolorów PRO-1000\Hahnemuhle Photo Rag Baryta 315”.

I suspect it doesn’t like non-ASCII chars in the path, spaces in the path, or more generally .icc paths outside of the system dir. I’ll investigate further.

Thanx to give us returns when you’ll have investigated.

Thanks for the reply … and I always install the icc-profiles in the standard path.

Btw, when you are going to ‘register’ a paper profile for softproofing, PL 6 / 7 remembers the location. So best is to have them in one place.

Okay, got it. It seems that PhotoLab cannot print anything (same error about Exif) if the color profile used for printing is placed into a directory with non-ASCII characters in the name.
Here are the tests I did:

  • Use .icc file from "C:\Users\robert\Desktop\profiletest" - works
  • Use .icc file from "C:\Users\robert\Desktop\profiletest space 2" - works, spaces are not the problem
  • Use .icc file from “C:\Users\robert\Desktop\profiletest_zażółć” - does not work, throws the error described above

I can easily reproduce this using the built-in PDF writer - no need to actually have a Canon PRO-1000.

This is quite confusing especially given that soft proofing works just fine, regardless of any international characters in the .icc file path. Looks like a bug to me.

So best is to have them in one place.

That is a good workaround. However, I like to have a directory per profile, because usually vendors will also ship an instruction manual with printer settings like: set the media type to such and such, use borderless print, etc.

For now, this lands in the “non-obvious bugs with viable workarounds” drawer for me.

While I use an Epson P800 – I’ve saved all necessary settings within the print driver. Otherwise it would be just a headache to select and not forget the appropriate option. Have a look if you can store / recall them.
.
papers with their printing speccifications – sorted by glossy / matte / colour / B&W

Screen Shot 10-09-23 at 11.11 AM

Screen Shot 10-09-23 at 11.11 AM 002 Screen Shot 10-09-23 at 11.11 AM 001